Számítógépes vírusokról általában...

A számítógépes rosszindulatú kártevő programok terjedése és a fertőzések elszaporodása egy fontos, és megoldandó biztonsági kérdés bármely számítógépes felhasználó számára. A következőkben rövid áttekintést adunk a rosszindulatú programok fajtáiról, az egyes változatok működéséről, terjedéséről.
A hagyományos értelemben vett vírusok legegyszerűbben megfogalmazva számítógépes programok, melyek veszélyeztethetik a számítógépen tárolt adatokat, és a rendszer működőképességét. Hasonlóan egy biológiai vírushoz, a számítógépes változat is reprodukálhatja magát, rendszerint hozzáfűződik egy hordozó (általában futtatható) fájlhoz, melyhez kapcsolódva biztosított a terjedése is. Amikor el vannak szigetelve (például egy tömörített fájlban) és nem működőképesek, akkor ártalmatlanok, nem veszélyesek, de kicsomagolás és működésbe lépés után nagy pusztításokat tudnak véghez vinni a számítógépes rendszerekben.
A köznyelvben összefoglaló néven 'vírusoknak' nevezett rosszindulatú programok terjedésük módja és tevékenységük szerint megkülönböztethetők egymástól.
Léteznek boot vírusok, amelyek a kilencvenes évek közepéig a legnagyobb veszélyt jelentették a vírusok között. Működésük során a számítógép boot szektorát fertőzik meg, mely a rendszerindítási folyamatokat vezérli. Az ilyen vírusok már a rendszer elindításkor működésbe léphetnek, és bár mára már kihaló félben vannak, érdemes őket megemlíteni.
A ma ismert vírusok nagy többsége a programvírusok közé sorolható, ugyanakkor, ha azt vizsgáljuk, hogy jelen pillanatban az összes aktív vírus között mekkora a részarányuk, ez a vezető szerep már nem mondható el. Ezek a vírusok a programokat, a DOS COM illetve EXE illetve a Windows NewEXE és a Windows95/NT Portable EXE formátumú végrehajtható állományait fertőzik. A fájlvírusok nagy többsége a programok végére illeszti saját kódját, ezen kívül végrehajt olyan változtatásokat, amelyek a program elindításakor automatikusan a vírus futtatását vonják maguk után.
A makro vírusok megjelenése csak alig pár éves múltra tekint vissza, mégis egyre jobban betolakodnak mindennapjainkba. Elsődleges célpontjuk a Microsoft Office csomagban szereplő programok által használt, makrókat futtató állományok, a dokumentumok megfertőzése. A levelezési szokások miatt egyre gyakori a dokumentumok e-mail-ekhez való csatolása, mely fokozza a terjedést.
A script vírusok csoportjába tartozó vírusok - mint nevük is utal rá - nem bináris programkódként terjednek, hanem forráskód formában. Emiatt a begyűjtött vírust bárki könnyedén módosíthatja, ezzel új vírusvariánst hozva létre.
Az Internet széleskörű elterjedése magával hozta az e-mail-ben terjedő vírusokat is, amelyek jelen pillanatban az első számú veszélyforrásnak tekintendők. Ezek a levelezőprogramokat távvezérelve, vagy a levelező szerverrel közvetlenül kommunikálva küldik tovább magukat esetenként több száz példányban. Ezek a fertőzött levelek felismerhetők arról, hogy mindig tartalmaznak valamilyen csatolt állományt, ami maga a vírus.
Az e-mail-ben terjedő vírusok egyik alfaja az úgynevezett féreg vírusok (worms), melyek önmagukat küldik szét, és kártékony hatásuk a kezelésükkel eltöltött időveszteségen kívül a rendszerek leterhelésében mutatkozik meg. A mai vírusok életciklusa felgyorsult. Egy tipikus levélvírus az első felbukkanása utáni fél napban viharos sebességgel terjed, azonban kb. 3 nap múlva (hála a víruskeresőkhöz kiadott frissítések rutinszerűvé váló gyors szétterítésének) már gyakorlatilag eltűnik a színről.
A számítógépes kártevők közé tartoznak az úgynevezett trójai programok is. Ezek maguktól nem terjedő programok, melyek valamilyen rejtett károkozó rutinnal rendelkeznek. Mivel önmaguktól nem terjednek, úgy lehet áldozatul esni egy trójai programnak, hogy egy Internetes oldalról letöltik őket, vagy levélben megkapják. Funkcionalitásuk szerint a trójai programok több csoportba sorolhatók.
A backdoor (hátsó ajtó) programok kiskaput nyitnak a megtámadott számítógépen a hálózatról érkező támadások számára.
A dialer (tárcsázó) programok a meglévő betárcsázós internet kapcsolatot változtatják meg úgy, hogy a helyi szolgáltató helyett titokban, egy távoli országban lévő Internet szolgáltatóval létesítenek kapcsolatot növelve a felhasználó telefonszámláját.
A jelszó lopó programok a betelepülés után igyekeznek begyűjteni a felhasznál jelszavait tartalmazó kódolt állományokat, és a memóriában kódolatlanul megtalálható jelszavakat, és ezeket egy meghatározott címre elküldik.
A fentiekből látható, hogy a vírusok széleskörű elterjedtsége és változatos megjelenése miatt indokolt a védekezés ellenük, a vírusirtó alkalmazások létjogosultsága napjainkra megkérdőjelezhetetlen a számítógépes biztonságtechnika területén..


Vírusfertőzésre utaló jelek

A fertőzésre utaló jelek erősen függnek az elszaporodott vírus sajátosságaitól. Néhány általánosnak mondható jel, melyekből következtetni lehet a számítógép megfertőződésére:
• Rendszeresen tapasztalható problémák a számítógépen, mint például fájl-másolási gondok.
• A számítógép gyakran magától újraindul, vagy leáll.
• A levelező partnerek jelzik, hogy e-mail címéről fertőzött leveleket kapnak.
• A számítógép futása érzékelhetően lelassul.
• Kevesebb szabad memória áll rendelkezésre, mint rendszerint.
• Menüpontok, funkciók vagy egész alkalmazások tűnnek el.
• A programok betöltésének ideje megnövekedik a számítógépes konfiguráció változtatása nélkül.
• A fájlok mérete hirtelen megnövekedik látszólag minden ok nélkül.
• Egyes vírusok egyszerűen közlik, ha sikerült megfertőzni a rendszert, megjelenítve egy üzenetet.
• Ha a fájl dátuma megváltozik.
• Nem fér hozzá egy olyan meghajtóhoz, amelyről biztosan tudja, hogy létezik a rendszerben.
• A képernyőn furcsa grafikus minták jelennek meg, például egy pattogó labda, stb.


Vírusmentes környezet fenntartása

A világon naponta több vírus indul útjára, hogy újult erővel indítson támadást a felhasználók és vírusirtó programok ellen. A felgyorsult terjedés miatt az új vírusok megjelenésüktől számítva néhány napon belül, nem ritkán órákban mérve megfertőzhetik a gyanútlan felhasználók számítógépeit.
A megelőzésre befektetett energia sokszorosan megtérül egy-egy komolyabb vírustámadás kivédésekor. A biztonsági óvintézkedések betartásával pedig elkerülhető, hogy saját vagy mások adatai megsérüljenek, elvesszenek. Néhány tipp a vírusmentes környezet fenntartására:
• A külső adattárolón érkező adatokat minden esetben vizsgáltassa át víruskereső programmal.
• Használjon folyamatosan működő (rezidens) vírusellenőrző programot.
• A vírusellenőrző program adatbázisát a lehető leggyakrabban frissítse.
• Levelezőrendszeren érkező állományokat kezelje fenntartással.
• A számítógép felhasználói jogosultságait megfelelő körültekintéssel alakítsa ki.
• Fontos a megosztott könyvtárak megfelelő kezelése. Állítson be hozzáférési jogokat, melyek korlátozzák az "idegen" felhasználók tevékenykedéseit.
• Csak jogtiszta programokat használjon.
• Használjon tűzfalat az esetleges külső behatolásokkal szemben.
• Kizárólag megbízható forrásból fogadjon el állományokat.
• Jelszavát kezelje körültekintően.
• Ha csak a gyanú is felmerül vírusfertőzésre, a merevlemezt vizsgálja át friss víruskeresővel.
• Bizalmas adatokat tároló számítógép használatát ne engedjük meg bárkinek.
A vírusok ellen csak megbízható és naprakész víruskereső, izoláló és irtó programok használatával lehet hatékonyan fellépni..


A keresőmotor

Termékeink alapját a VirusBuster kiemelkedő teljesítményű keresőmotorja képezi. A károkozók felderítéséhez heurisztikus vírusfelismerést is használ, platformtól- és operációs rendszertől független keresési technológiájának köszönhetően bármely rendszeren hatékonyan deríti fel a vírusokat, férgeket, trójai programokat, scripteket, makrovírusokat, adware és spyware-eket és egyéb kártékony kódokat akár tömörítvényekben is. Ezen felül a motor hatékonyabb vizsgálatukhoz emulációs technológiát is használ.
A keresőmotor főbb tulajdonságai:
• Heurisztikus víruskeresés
• Kiemelkedő sebesség
• Processzor/PC emulációs technológiák amennyiben lehetséges
• 99%-ban platform független víruskereső motor (a maradék 1%, a platform függő részek implementációja)
• Könnyen kezelhető vírus adatbázis: bármilyen új fájltípus egyszerűen beépíthető
• Független keresési technológiák használata
• Napi gyakoriságú adatbázis frissítés
• Processzor/platform független vírus adatbázis és keresési technológiák
• operációs rendszer független fájl típus felismerés és kezelés
• Natív keresés .tar, .gz, .bzip2, .zip, .rar, .arj, .ace, .chm, TNEF, ms cab archives és install shield cab fájlokban
• Natív keresés a követezőkkel tömörített fájlokban: diet, upx, aspack, pecompact és fsg (egyéb .exe tömörítvények átvizsgálása emulációs technológiával)
• Tömörítvények átvizsgálása bármilyen szint mélységig (erőforrástól függő)
• Vírusok, férgek, trójai, és egyéb ártó kódok felismerése
• Kémprogramok (spyware) és hirdetőprogramok (adware) felismerése és eltávolítása
• Információ-nyújtás a teljes levél törlésével eltávolítható IWORM-ökről
• Keresés futtatható fájlokban
• Keresés Microsoft Word, Excel, PowerPoint, Access és Project fájlokban
• Keresés beágyazott OLE objektumokban
• Keresés az új Office 2003 XML formátumban
• Keresés HTML, Java script, ActiveX és Visual Basic Script (VBS) fájlokban
• Keresés egyéb script nyelveken írott fájlokban, mint például Unix / Linux shell script-ek
• Keresés a Windows Help fájlokban (HLP)
• Keresés LNK és PIF fájlokban
• Beépített MIME értelmező az e-mail-ek, mail box-ok és MHT fájlok ellenőrzésére
• Támogatott kódolási típusok: BinHex 4.0, Base64, Quoted-printable, UUEncode
• Natív keresés Outlook Express mail box-ban


VIRUSBUSTER PROFESSIONAL 2006

Napjainkban az Internet felől érkező vírusok és egyéb károkozók száma rohamosan nő, így mind az otthoni felhasználóknál, mind a cégeknél elengedhetetlen a munkaállomások hatékony védelme. Egy esetleges vírusfertőzés nem csak adatvesztést okozhat, hanem a helyreállítással eltöltött idő és az arra költött pénz is komoly veszteségeket jelenthet a felhasználók számára

A VirusBuster Professional átfogó, teljes védelmet nyújt minden munkaállomás számára. A rezidens fájl védelem mellett a Microsoft Office alkalmazásokba integrálódva védi irodai munkánkat, levelezésünket és az Internet felől érkező károkozókat is felismeri és eltávolítja, akár levelezés közben, akár az Internet böngészése közben.

A VirusBuster Professional-ban található Office megoldás egy olyan plug-in védelem, amely az MS Office (Word, Excel, PowerPoint, Outlook, Access) rendszereibe épülve a kititkosítás után, de még a futtatás előtt ellenőrzi a dokumentumokat, leveleket. Így a titkosított dokumentumot a VirusBuster Professional használata esetén továbbra is csak a küldő és fogadó személy látja, központi összegyűjtés, kititkosítás és ellenőrzés nem történik.
A termék főbb tulajdonságai:
• Hatékony védelem számítógépe számára a vírusokkal szemben
• Egyszerűen használható, varázsló alapú felület
• Bővített felület a tapasztaltabb felhasználóknak
• Feladat orientált működés
• Inkrementált vírusadatbázis frissítés
• Kézi, automatikus és időzített víruskeresés
• Állandó védelem választható védelmi szintekkel
• Feladat orientált, moduláris frissítések
• Intelligens karantén a fertőzött fájlok elkülönítésére
• MS Office alkalmazásokba integrált védelem az irodai munka biztonságáért
• Microsoft Outlook-ba integrált levelezésvédelem
• Windows Security Center támogatása


Eltávolítás, módosítás, javítás

Amennyiben el szeretné távolítani gépéről a VirusBustert, vagy módosítani szeretné a telepített összetevőket, esetleg újratelepíteni a telepített komponenseket, a következőket kell tennie:
• Kattintson a Windows Start menüben a Beállítások között a Vezérlőpultra, majd a Programok telepítése és törlése ikonra!
• A megjelenő listában keresse meg és jelölje ki a az eltávolítandó terméket!
• Kattintson a kijelölt termék melletti |Módosítás/eltávolítás| gombra!
A megjelenő ablakban aztán kiválaszthatja a kívánt műveletet:
• Módosítás
E művelet kiválasztásának hatására, ha továbblép (|Következő >| gombra kattintás), a megjelenő komponenslistából – az előttük üresen álló jelölőnégyzet bejelölésével – kiválaszthatja a program újonnan telepítendő funkcióit, illetve megszüntetheti a kijelölést a már telepített, de most eltávolítani kívánt funkciók előtt. Továbblépve a műveletek (telepítés/eltávolítás) végrehajtásra kerülnek.
• Javítás
A telepített funkciók újratelepítése.
• Eltávolítás
Az összes telepített funkció eltávolítása a rendszerből.


Indítás a Start menüből

A VirusBuster termékcsalád programjai telepítésük során a Start / Programok / VirusBuster útvonal alatt kerülnek regisztrálásra. Itt találhatók a feltelepített termékkel kapcsolatos parancsikonok, innen indítható el a termék, illetve a termékinformációkat tartalmazó különböző dokumentációs fájlok hivatkozásai is itt kaptak helyet.
A program indítása a következő parancsikonnal lehetséges:
• VirusBuster 2006 Konzol
A termékek általános összefoglaló varázsló alapú grafikus felhasználói felülete, melyről a telepített komponenseket vezérelheti.
Megjegyzés!
Több különböző VirusBuster program telepítése esetén az egyes termékek együttesen a fent említett parancsikonnal vezérelhetők!

A parancsikonok között találhatók még a dokumentációs fájlok (Súgó), melyek részletes információt tartalmaznak a termék használatával, működésével kapcsolatban. A telepített komponensek és funkciók nem csak az összefoglaló felületről irányíthatók, hanem egyenként is elindíthatók a VirusBuster Komponensek könyvtárból, amennyiben a VirusBuster konzol nem fut. Ha egy komponens nem a konzolról lett elindítva, akkor amíg használatban van, addig nem lesz elérhető a konzolból, ha az időközben elindításra kerül.


Tálca

A VirusBuster a tálcáról is elérhető, telepítés után a jobb alsó sarokban megjelenő VB ikon jelzi, hogy a termék jelen van a rendszerben.
Az ikonon található kis pajzs jelzi az Állandó védelem funkció állapotát, mely folyamatos vírusvédelmet biztosít a rendszer számára (ha nincs telepítve ez a funkció, a pajzs nem látható). A pajzs színe információt közöl a védelem állapotáról:
• Zöld
Az Állandó védelem aktív, a rendszer vírusvédelme biztosított (amennyiben a termék regisztrált, vagy a kipróbálási periódusban van).
• Szürke
Az Állandó védelem nem működik, nincs folyamatos vírusvédelem.
A tálcáról könnyedén és gyorsan elérheti a program legfontosabb funkcióit, indíthatja a gyakorta használt komponenseket, feladatokat. A VB ikonra (1) történő jobb egérkattintásra megjelenő helyi menüből választhatja ki a kívánt funkciót. Amelyik menüelemből további menüpontok nyílnak, azt a menüpont neve előtt álló kis nyíl jelzi (2).
A menüben mindenképpen rendelkezésre állnak a következő menüpontok:
• Regisztráció
E menüpont alatt találhatók a program megvásárlásával, regisztrálásával kapcsolatos funkciók, ezekről részletesen a Vásárlás, regisztráció, aktiválás fejezetben olvashat.
• Támogatás
Ez az összefoglaló menüpont három menüpontot tartalmaz, melyek a következők:
Súgó
A Súgó menüpontban a feltelepített termékekkel kapcsolatos dokumentációs fájlok érhetők el.
Forduljon hozzánk
E funkció kiválasztásakor e-mail üzenetet küldhet a VirusBusternek a termékkel kapcsolatban, amennyiben a Levelező komponens telepítésre került (részletesen a Levélküldés fejezetben).
Információk
A VirusBuster honlapját tekintheti meg, ha e menüpontra klikkel.
Regisztrálás után, vagy a kipróbálási periódus alatt a fontosabb telepített komponensek, illetve a rendelkezésre álló keresési vagy frissítési feladatok is elérhetők a menüből. A menüre történő dupla egérkattintással pedig a VirusBuster Konzol is elindítható.


Felugró ablakok

A Tálca felett megjelenő kis kék információs dobozok – felugró ablak üzenetek – segítségével a felhasználók gyorsan és közvetlenül kapnak tájékoztatását a rendszerben történt fontosabb eseményekről, a védelem állapotáról.
A címben a vastagon kiemelt modulnév mutatja a megjelenített üzenet „feladóját”, e modul küldi az üzenetet, az ő működésével kapcsolatban közöl információt a rendszer. Némely esetben a tájékoztató dobozon egy gomb is helyet kap, melyre kattintással közvetlenül elérhető a felajánlott funkció (például vírusadatbázis frissítésének figyelmeztetésekor a |Frissítés| gombra kattintással azonnal megkezdheti a frissítést).

A felugró ablakok a megjelenésük után egy kis idővel maguktól bezáródnak, a doboz jobb felső sarkában található |X| gombra kattintással a felhasználó maga is bezárhatja az ablakot.


Vásárlás, regisztráció, aktiválás

A feltelepített vírusvédelmi program az első telepítéstől számított 30 napig teljes funkcionalitásában használható. Ezalatt az úgynevezett ’Kipróbálási időszak’ alatt a felhasználó megismerkedhet a termékkel, hozzáfér az összes beállítási lehetőséghez, és a vírusirtási funkciók mindegyike használható. A program teljes értékű vírusvédelemnek tekinthető ez időszak alatt, egyetlen különbség van csak a regisztrált termék működéséhez képest, hogy gyakran figyelmezteti a felhasználót egy üzenet ablak segítségével (komponensek indításakor), hogy kipróbálási periódusban van, és regisztrálja a terméket a rendelkezésre álló módok valamelyikén keresztül. Ilyenkor választhat a felkínált lehetőségek közül: megvásárolhatja, regisztrálhatja, aktiválhatja a programot, vagy – kizárólag a kipróbálási periódus alatt – választhatja a |Később| gombot, mellyel továbbléphet, elindíthatja a terméket (a vásárlást, regisztrációt, aktiválást későbbre halaszthatja). A |Bezár| gombbal kilép a programból.

Vásárlás

A vásárlás funkció elérhető az előugró ablakban a |Vásárlás ...| gombra kattintással. A program a VirusBuster honlapjára irányítja a felhasználót, melyen keresztül on-line megvásárolhatja a terméket – ez e-mail-en történő licenc-megrendelést jelent – melynek keretében hozzájut a regisztrációs adatokhoz, ezeket a termékbe beírva regisztrálhatja programját.

Regisztráció

A termék a feltelepítés után 30 napig teljes funkcionalitásban használható, ez a kipróbálási időszak. Ezt követően érvényes regisztrációs kulcs megadása nélkül már nem indítható. A regisztrációs adatok bevitelére szolgáló panel elérhető az előugró ablakban a |Regisztráció ...| gombra kattintással, illetve a tálcán található VB ikon gyorsmenüjéből.

A regisztrációs panelon a Termék neve: lenyíló ablakból kiválasztható a regisztrálni kívánt termék neve (egyszerre több termék is lehet telepítve a gépen). A kiválasztott termékhez rendelkezésre álló regisztrációs adatokat a Felhasználó neve: és a Regisztrációs kulcs: mezőkbe kell begépelni. Ezután a |Regisztrálás| gombra kattintva – érvényes regisztrációs adatok megadása esetén – a termék regisztrálása megtörténik, és a lejárati időpont később megtekinthető a panelon. Az ablak felső részében egy zöld sávban a Regisztrált felirat lesz látható.

A regisztráció lejárta után a termék teljes funkcionalitásban használható, egészen egy esetleges programfrissítésig. A termékek licencelése alapján a termékfrissítések felhasználási joga csak a licenc perióduson belül lehetséges! Ennek értelmében a regisztráció lejártát követően a terméket frissíteni csak abban az esetben lehet, ha a licenc meghosszabbításra–, valamint a regisztrációs kulcs frissítésre került. Ellenkező esetben a termék frissítése a beépített korlátozás következtében annak működésképtelenségét vonja maga után. A fenti korlátozás a vírusadatbázisra nem vonatkozik, az időkorlátozások nélkül felhasználható a termékhez (a regisztrációs periódus lejártát követő vírusadatbázis frissítés után a program működőképes marad), de garanciát a kompatibilitás megtartására nem vállalunk.

Aktiválás

Az aktivációs folyamat során a felhasználó az aktivációs kulcs (3x4 karakter) birtokában kérheti meg az Interneten (on-line) terméke regisztrációs kulcsát (3x5 karakter). Az aktiváció nem regisztrálást jelent, hanem a regisztrációs kulcshoz való hozzájutás folyamata. Az aktiváláskor igényelt regisztrációs periódus kezdete az aktiváció időpontja lesz, és a licenc szerződésben meghatározott ideig tart.
Az aktivációs panel elérhető az előugró ablakban az |Aktiválás ...| gombra kattintással. Aktivációs kulcshoz elsősorban kiskereskedelmi értékesítési formákban (pl: OEM licenc hardverhez vagy internet szolgáltatáshoz) megvásárolt VirusBuster termék esetében juthat hozzá.


Felhasználói felület

A VirusBuster programok egységes megjelenéssel rendelkeznek, mely közös vezérlési felületet biztosít a termékeknek. A telepített programok indítása ugyanazon parancsikonnal lehetséges (lásd: Indítás a Start menüből), a közös felhasználói felületről a feltelepített vírusvédelmi komponensek mindegyike elérhető.
Figyelem!
Ha a Windows-ba bejelentkezett felhasználó nem rendelkezik rendszergazdai jogosultsággal (korlátozott jogú felhasználó), akkor bizonyos opciók és beállítások nem lesznek elérhetők számára a felhasználói felületen.
A VirusBuster termékeit varázsló alapú felhasználói felülettel látta el, melynek segítségével a felhasználó egyszerűen állíthatja be a vírusvédelem paramétereit. A megjelenő grafikus felületen a funkciók beállítása lépésről-lépésre végezhető el, az egyes beállítási panelok leírásai segítséget nyújtanak az opciók értelmezéséhez.
A védelemi komponensek beállítása a varázsló alapú felületen két szinten végezhető el, melyek a következők:
• Egyszerű felhasználói felület
E felület kifejezetten a kezdő, kevés tapasztalattal rendelkező felhasználók számára készült, ahol nem kell részletes beállításokat elvégezni a program működtetéséhez, elég a legfontosabb paramétereket meghatározni, a védelem a szükséges mértékben testre szabható az előre definiált beállítás-kombinációk segítségével.
• Bővített felhasználói felület
A tapasztaltabb felhasználók számára készült, melyen az összes fontos beállítás elérhető és módosítható, a rendszer teljes mértékben testre szabható.
A felületek között az egyes beállítási panelok alján megjelenő |Bővített| – |Egyszerű| gomb-párossal váltogathat.
Figyelem!
A Bővített felhasználói felületről az Egyszerűre történő váltás esetén előfordulhat olyan beállítás, mely nem felel meg az egyszerűsített felületen megtalálható beállítás-kombinációk egyikének sem. Ilyenkor – ha folytatja az átváltást – a Bővített panelon meghatározott beállítások elvesznek, helyükre az Egyszerű felületen is értelmezhető beállítás-kombináció kerül!

A felület felépítése

A Start menüből – VirusBuster Konzol parancsikonnal – történő indítás után megjelenik a VirusBuster kezelőfelülete. E grafikus felületen a menük és a beállítási panelokon keresztül állíthatja be a szükséges vírusvédelmi paramétereket, kezdeményezhet víruskeresést, küldhet üzenetet, stb.
Indításkor a Főoldal jelenik meg, mely általános információkat közöl a programról. Megtekintheti a rendszerben telepített VirusBuster termékek–, és a legfontosabb komponensek verzióját, állapotát. A |Frissítés| gombbal kezdeményezheti a vírusadatbázis frissítését. Tájékozódhat az Állandó védelem állapotáról, a vírusadatbázis frissességéről. A használt jelölések és jelentésük:
A szolgáltatás aktív / Vírusadatbázisnál: az adatbázis 7 napnál újabb, naprakész.
A szolgáltatás ki van kapcsolva / Vírusadatbázisnál: az adatbázis 7 napnál régebb.
A szolgáltatás nincs telepítve / Vírusadatbázisnál: hiba a vírusadatbázissal.
A vezérlő felületen a menük (3) segítségével tekintheti meg az egyes komponensek beállításait. A menük valamelyikére kattintás után a komponensek állítható opciói, beállításai jelennek meg a beállítási területen (6). Ilyenkor a menüben (3) a kiválasztott komponens almenüi láthatók, ezeken keresztül elérheti az adott komponensen belüli egyéb funkciókat, beállításokat, vagy tájékozódhat arról, hogy mely lépésnél is tart éppen egy esetlegesen több lépésből álló beállítási folyamatban. A Főoldalra a navigációs panel (2) házikó ikonjára kattintással kerülhet vissza, a navigálás egyes lépései a balra és jobbra nyíllal oda-vissza bejárhatók.
Varázsló alapú felhasználói felület
A felület felépítése:
1 Fejléc
Az ablak fejléce, VirusBuster logo.
2 Navigációs panel
Navigálás a kiválasztott menüpontok és panelok között. A balra nyíllal az előzőleg megtekintett panel(ek)re, menü(k)re térhet vissza sorjában, a jobbra nyíllal pedig lépésben visszatérhet az utolsó állásba, ahonnan visszalépett. A kis ház alakú képre kattintással a Főoldalra kerül. A lakat szimbólum az opciók módosíthatóságát jelzi (Adminisztráció).
3 Menü
A menüpontokon keresztül érheti el a feltelepített komponensek beállítás, kezelési paneljét.
4 Kilépés
A programból bármikor kiléphet a |Kilépés| gombra kattintással.
5 Panel vezérlő gombok
A beállítási panelok legtöbbjén alul számos – beállítást megkönnyítő, folyamatot kezdeményező – gomb kapott helyet, melyek segítségével váltogathat az egyszerűsített és a bővített felületek között, végigvihet egy-egy beállítási folyamatot, vagy esetleg elindíthat egy kiválasztott feladatot.
6 Beállítási terület
A menüben (3) kiválasztott menüpontnak megfelelő komponens, opció, művelet beállítási panelje jelenik meg ezen a területen, itt történik a beállítások, paraméterek meghatározása, az egyes feladatok felvétele, indítása.
7 Súgó
Az éppen aktuális panel beállításaival kapcsolatban kérhet segítséget.

Kompakt felhasználói felület

A termék felhasználói felületének egy része kisebb képernyőfelbontást használva "kilóghat" a képernyőről, ilyenkor egyes menüpontok vagy beállítások lehet, hogy nem teljes egészében láthatók. Az ilyen felbontásban használt képernyőkön megoldás lehet a felhasználói felület kompakt nézetbe történő átváltása, mely a VirusBuster ablak jobb felső sarkában található egyik vezérlőgomb segítségével állítható be. Ugyanezen gomb megnyomására kompakt módból ismét normál nézetre kapcsolható a felület.
Figyelem!
640X480-as felbontás esetén csak a kompakt megjelenési forma érhető el, ebben az esetben az ezt a módot aktiváló vezérlőgomb nem jelenik meg.

Kompakt nézetben a bal oldali menüsáv eltűnik, ezzel a felület kevesebb helyet foglal a képernyőn. A menüt a bal oldalon megjelenő sávra kattintással lehet elérni, ilyenkor a menü a beállítási panel egy részét eltakarva jelenik meg. A kívánt menüpont kiválasztása után szintén a bal oldali sávra kattintva tüntetheti el a menüt.


Víruskereső motor tesztelése

A víruskereső motor leteszteléséhez felhasználhatja az EICAR (European Institute of Computer Anti-virus Research) szabványos vírusellenes teszt állományát, mely valójában nem egy igazi vírus, de a VirusBuster víruskereső motor felismeri. Ahhoz, hogy létrehozzon egy állományt, melyben jelen van az EICAR szekvencia, írja be a következő sort egy üres állományba, és mentse el egy .COM kiterjesztésű fájlba (például EICAR.COM):
X5O!P%@AP[4\PZX54(P^)7CC)7}$EICAR-STANDARD-ANTIVIRUS-TEST-FILE!$H+H*
A víruskereső motor működésének ellenőrzéséhez végezzen vírusellenőrzést a létrehozott fájlon, vagy ha az Állandó védelem aktív, futtassa a fájlt. Ha a motor helyesen működik, a keresés, vagy futtatás eredményeként egy figyelmeztető ablakban jelenik meg a fájllal kapcsolatban.
Megjegyzés!
Ha ezt a COM fájlt lefuttatja, és az Állandó védelem nincs bekapcsolva, kiírja az "EICAR-STANDARD-ANTIVIRUS-TEST-FILE" üzenetet, majd kilép.


A vírusvédelem felépítése

A VirusBuster termékek modulokból állnak, a program komponensei együttesen alkotják a vírusvédelmet. A továbbiakban az egyes komponensek működése, felépítése kerül bemutatásra.


Állandó védelem

A komponens futása során folyamatos védelmet nyújt a vírusok ellen. Fő feladata háttérben működve a vírusok keresése és irtása a napi tevékenységek végzése közben. A védelem fájl-hozzáféréskor (pl: írás, olvasás) ellenőrzi az aktuális fájl fertőzöttségét. Az állandó védelem beállításai a következő panelokon végezhetők el:
• Beállítások
• Keresési területek
• Statisztika

Beállítások

A védelmi beállítások a Beállítások panelon végezhetők el. Gyorsan és egyszerűen konfigurálhatja a védelmet az egyszerűsített panelon, vagy részletesebben a szélesebb körű beállításokat lehetővé tevő bővített panelon, melyet a |Bővített| gombra kattintással érhet el.

Egyszerűsített beállítások

A védelem aktív, ha a Bekapcsolva jelölőnégyzet be van jelölve. Ezen kívül, a panelon előre definiált védelmi szintek közül választhat egyszerűen és gyorsan meghatározva a védelem erősségét. A védelmi szintek egyfajta beállítás-kombinációt jelentenek, melyek a Bővített panelra történő átváltáskor megjelennek a beállítások értékeként.
A védelmi szintek, és jelentésük:
• Erős
Alapos víruskeresési módot- és Erős heurisztikát használ, az irtható vírusokra az Irtás, a nem irthatókra pedig a Karanténba mozgatás műveletet alkalmazza. Heurisztikus találatkor a művelet: Meghagyás.
• Közepes
Alapos víruskeresési módot- és Közepes heurisztikát használ, az irtható vírusokra az Irtás, a nem irthatókra pedig a Meghagyás műveletet alkalmazza. Heurisztikus találatkor a művelet: Meghagyás.
• Gyenge
Gyors víruskeresési módot használ, nem használ heurisztikus keresést, az irtható vírusokra az Irtás, a nem irthatókra pedig a Meghagyás műveletet alkalmazza.
• Egyedi beállítások
A beállítás nem választható, akkor lesz kijelölve, ha a Bővített panelon olyan beállítás-kombináció jön létre, mely nem fedi le egyik előre definiált védelmi szint beállításait sem.

Bővített beállítási lehetőségek

A Bővített panelon az Állandó védelem opció bekapcsolásával a védelem aktívvá tehető.

A Figyelmeztetések megjelenítése opció engedélyezésével a felhasználó figyelmeztető üzenetben értesül az esetleges vírusincidensekről, míg ha ez a funkció nincs engedélyezve, a program elvégzi ugyan a beállított műveleteket, de az incidensekről a felhasználó nem kap a napló bejegyzéseken kívül semmi visszajelzést.
A keresési mód a következő szinteken szabályozható:
• Gyors/Alapos/Teljes
Heurisztikus keresés beállítása a következő szinteken lehetséges:
• Kikapcsolva/Normál/Erős
A Találati beállítások leírását lásd a Kereső fejezet hasonló beállításánál!
Választható műveletek Vírustalálat esetére:
• Irtás/Meghagyás/Átnevezés/Karanténba mozgatás/Törlés
Választható másodlagos művelet és beállítás heurisztikus találat esetén:
• Meghagyás/Átnevezés/Karanténba mozgatás/Törlés

Keresési területek

E panelon beállíthatja a védelem által ellenőrizendő fájlok típusát, meghatározhatja az ellenőrzésből kizárandó útvonalakat.

A Minden fájl ellenőrzése beállításnál az összes típusú (kiterjesztésű) fájl hozzáféréskor ellenőrzésre kerül.

Meghatározott kiterjesztések ellenőrzésekor csak a felhasználó által kiválasztott kiterjesztésű fájlok kerülnek ellenőrzésre hozzáféréskor. A fájltípusok beállításának ismertetése a Kereső komponens Kiterjesztések beállítása bekezdésben található.

A Kizárandó útvonalak ablakban fa szerkezetben láthatók a számítógépen található lehetséges meghajtók és útvonalak. A felhasználó itt kiválaszthatja, hogy mely útvonalakat ne védje a program, és így a kiválasztott útvonalakon található fájlok hozzáféréskor nem kerülnek vírusellenőrzésre. A könyvtárak előtti kis plusz jel jelzi, hogy a könyvtár tartalmaz alkönyvtára(ka)t. A plusz jel mínusz jelre vált, ha az adott könyvtár nyitva van, és látszanak az alkönyvtárai is. Egy könyvtárat kinyitni a névre való dupla-, vagy a plusz jelre való szimpla egérkattintással lehet. A könyvtárak előtti kis négyzet bejelölése jelenti az adott könyvtár kijelölését (a benne található fájlok nem kerülnek vizsgálat alá hozzáféréskor). Fontos, hogy nyitott, vagy zárt állapotban jelöl ki-, vagy vesz le kijelölést egy könyvtárról, mert nyitott állapotban, ha a főkönyvtár kijelölésre kerül, ez nem vonatkozik az alkönyvtáraira (nem rekurzív). Ez igaz a kijelölés megszüntetésére is. Zárt állapotban a kijelölés vonatkozik a kijelölt könyvtár összes alkönyvtárára is (rekurzív) és ez igaz a kijelölés megszüntetésére is. A rekurzívan kijelölt könyvtárak egy mellettük megjelenő csillaggal (*) vannak jelezve.

Hálózati számítógép esetén hálózati megosztásokat is felvehet kizárásra a |Hálózat...| gomb segítségével. A megjelenő ablakban ki kell választani az ellenőrizni kívánt útvonalat, majd a |Hozzáad| gombbal hozzáadhatja a már meglévő útvonalak közé.
Könyvtárak megjelölési szintjének három állapota lehetséges:
• Fekete pipa szerepel a könyvtár előtti négyzetben.
A megjelölt könyvtár és – összes esetleges – alkönyvtárai ki vannak jelölve, az ezekben található fájlok nem kerülnek ellenőrzésre hozzáféréskor.
• Nincs fekete pipa a könyvtár előtti négyzetben, de vastag betűvel szedett a könyvtárnév.
Ilyenkor az adott könyvtárnak létezik olyan alkönyvtára, mely ki van jelölve. Az ebben az alkönyvtárban található fájlok nem kerülnek ellenőrzésre hozzáféréskor.
• Nincs fekete pipa a könyvtár előtti négyzetben, normál betűvel van szedve a könyvtárnév.
A könyvtár és egyik alkönyvtára sincs kijelölve, a benne lévő fájlok, és alkönyvtárak fájljai is ellenőrzésre kerülnek hozzáféréskor.

Statisztika

Az állandó védelem által vizsgált fájlok és az észlelt fertőzések összesített megjelenítése. A panelon látható még a védelem által utoljára felderített vírus neve és találati helye.


Tartalomszűrő

A VirusBuster tartalomszűrő szolgáltatása védelmet biztosít kliens számítógépek számára a hálózaton (Internet) érkező károkozók ellen. A tartalomszűrő komponensek a hálózaton történő kommunikációt vizsgálják, víruskeresést hajtanak végre az általuk ismert protokollok adatforgalmán.
Figyelem!
A Tartalomszűrő egyes protokollok esetén az alábbi korlátozásokkal használható:
IMAP protokoll esetén: Olyan IMAP letöltéseknél, ahol a kliens a levelet darabokban szedi le, a Tartalomszűrő nem képes a károkozókat kimutatni, illetve nem támogatott olyan kliens használata, amely több szálon kommunikál a szerverrel (pl: The Bat!).
HTTP protokoll esetén: Több szálon töltő kliensek használata esetén nem működik a vírusellenőrzés (különböző letöltést menedzselő programok).
Minden protokoll esetén: Nem ellenőrzi a 2 MByte feletti fájlokat.
A szűrési beállítások a következő panelokon végezhetők el:
• Beállítások
• Keresési opciók
• Statisztika

Beállítások

A modul általános beállításai elvégezhetők az egyszerűsített panelon, vagy a szélesebb körű paraméterezést lehetővé tevő bővített panelon, melyet a |Bővített| gombra kattintással érhet el.

Egyszerűsített beállítások

A tartalomszűrő funkció protokollonként ki- illetve bekapcsolható. A Bekapcsolva jelölőnégyzetbe kattintással lehet aktivizálni a védelmet külön-külön a rendelkezésre álló protokollokon.
• Levelezés szűrés
A POP3 és IMAP levelezési- és SMTP levelezés-továbbítási protokollt használó elektronikus levél-forgalom vírusvédelmét biztosítja. A |Beállítások| gombra kattintás után egy új panelon kiválaszthatja a védeni kívánt protokollokat. Innen a |Vissza| gombbal kerül ismét a Beállítások panelra.
• Böngésző (HTTP) szűrés
A HTTP protokollt használó elektronikus adatforgalmat vizsgálja és védi.
• Fájlátvitel (FTP) szűrés
A FTP protokollt használó elektronikus adatforgalom vírusvédelmét biztosítja. Jelenleg a letöltéskori (download) adatforgalom-vizsgálat támogatott.

Bővített beállítások

A kommunikációs protokollok különböző portokon keresztül kommunikálnak a külső egységgel, az ezeken a portokon átmenő adatforgalom vírusellenőrzésének beállítása végezhető el e panelon. Beállítható, hogy mely portok adatforgalma legyen ellenőrizve a kiválasztott protokollok tekintetében, illetve mely hálózati címről érkező adatokat tekintse megbízhatónak (ne ellenőrizze) a rendszer.

A Protokoll legördülő listából válassza ki azt a protokoll típust, amelyen keresztül folyó adatforgalmat védeni szeretné. A protokoll kiválasztása után az Ellenőrizendő portok beállításnál adja meg azt a portszámot (azokat a portszámokat, melyen keresztül a kiválasztott protokoll adatforgalmának ellenőrzését meg szeretné valósítani). Ezt úgy teheti meg, ha a beviteli mezőbe beírja a kívánt értéket, majd a |Hozzáad| gombbal hozzáadja a vizsgálandó portok közé. A listából úgy törölhet egy értéket, ha kijelöli azt, és megnyomja a |Töröl| gombot. Ha a kiválasztott protokollt az összes létező porton védeni szeretné, jelölje be a Minden port ellenőrzése jelölőnégyzetet (jelentős hálózati igénybevételt jelent). Ha a Protokoll legördülő listában a Minden protokoll értéket választja ki, akkor az ehhez az értékhez beállított portokon az összes protokoll adatforgalma vírusellenőrzésre kerül.

A Megbízható IP címek beállításban a legördülő listából kiválasztott protokollhoz rendelhetők olyan IP címek is, amelyekről a beérkező adatforgalom nem kerül ellenőrzésre. A beviteli mezőbe beírt helyes IP cím a |Hozzáad| gombbal kerül a megbízható címek listájába, amit később a listából kiválasztva a |Töröl| gombbal távolíthat el. Az előbbiekhez hasonlóan, a Minden protokoll érték kiválasztásakor a rendszer az ehhez az értékhez beállított IP címet minden protokoll esetében megbízhatónak tekinti.

Az alapértelmezett beállítások alapján a rendszer a leggyakrabban előforduló portokon ellenőrzi az egyes protokollokat.

Keresési opciók

A víruskeresés módjának beállításai végezhetők el ezen a panelon.
A keresési mód a következő szinteken szabályozható:
• Gyors/Alapos/Teljes
Heurisztikus keresés beállítása a következő szinteken lehetséges:
• Kikapcsolva/Normál/Erős
A Találati beállítások leírását lásd a Kereső fejezet hasonló beállításánál!
Választható műveletek Vírustalálat esetére:
• Irtás/Karanténba mozgatás/Meghagyás/Törlés
Választható másodlagos művelet és beállítás heurisztikus találat esetén:
• Karanténba mozgatás/Meghagyás/Törlés
Az Interaktív kommunikációt választva minden egyes incidens esetén a felhasználótól vár beavatkozást a program, és az itt beállított akciókat ajánlja fel alapértelmezettként. Ellenkező esetben a beállított akciók automatikusan végrehajtódnak a fertőzött fájlon.
A Keresés tömörítvényekben beállítással határozhatja meg, hogy a program keressen-e vírusokat a tömörített fájlok belsejében is.
Megjegyzés!
HTTP és FTP forgalom ellenőrzése közben, Törlés, illetve Karanténba mozgatás akciók esetén amellett, hogy a kért művelet végrehajtódik a fájlon (törli, vagy karanténba mozgatja a fájlt), az adott fájl (neve és kiterjesztése) megmarad az eredeti letöltési helyen is, tartalma azonban egy szöveges üzenet lesz, melyben a felhasználó tájékoztatást kap a törlési, vagy karanténba mozgatási művelet végrehajtásáról. Az így létrejött (szöveggel feltöltött) futtatható fájlok indítása hibaüzenetet eredményez, mert a rendszer nem tudja értelmezni a kiterjesztés szerint futtatható–, ténylegesen pedig szöveggel feltöltött állományt.

Statisztika

A beállított protokoll(ok)on áthaladt forgalom vizsgálatának eredményéről, az előforduló esetleges incidensekről tájékozódhat az összesített statisztikai táblázatban.

A |Frissítés| gombbal aktualizálhatja az adatokat.


Programfrissítés

A program és a vírusadatbázis naprakészségének biztosítás alapvető feladat a védelem hatékonyságának fenntartásához.

A programfrissítés szintén feladat alapon működik: előre beállított paraméterek alapján a frissítés pár kattintásra indítható, vagy egy időpontra, eseményre ütemezhető. A programfrissítő feladatok elkészítése és esetleges módosítása a Programfrissítő modulban végezhető el, melyben lépésről-lépésre szerkesztheti meg a feladato(ka)t, beállítva a frissítéshez szükséges opciókat, paramétereket.
A termék a vírusadatbázis napra készen tartásához inkrementális adatbázis frissítési mechanizmust használ. A módszer lényege és előnye, hogy frissítéskor a programnak nem kell letöltenie mindig a teljes (több megabájt méretű) vírusadatbázis csomagot, hanem általában csak egy kisebb kiegészítő adatbázis fájlt, mely az utóbbi időben megjelent és feldolgozott károkozók felismeréséhez és eltávolításához szükséges információkat tartalmazza. Ezzel a módszerrel a napi frissítések időtartama a töredékére csökken, így lehetőség van akár naponta többször is vírusadatbázis frissítés kiadására, mely növeli a vírusvédelem hatékonyságát. Az egyes újonnan megjelenő károkozók elleni védelem a károkozók feldolgozása után szinte azonnal, minimális hálózati forgalom és letöltési idő ráfordítással eljut a felhasználókhoz.

A Feladatok menüpontban az Engedélyezett frissítési források beállításnál az engedélyezni kívánt frissítési forrás előtti jelölőnégyzetbe kattintva a megjelölt forrás aktív állapotba kerül, azaz lehetséges rajta keresztül a frissítés; kiválasztható lesz majd egy új feladat felvitele, módosítása során. Mindegyik feladat csak a hozzárendelt frissítési forrásról próbálja meg elévégezni a frissítést. A frissítési forrás adatai a beállítás neve mellett olvashatók, ezek megváltoztatásához kattintson a |Forrás beállítások ...| gombra. Kattintás után egy új ablakban lehet meghatározni az egyes forrásokhoz tartozó paramétereket. A legördülő listából kiválasztott elemhez a szükséges beállítások a panel alsó részén végezhetők el.
Megjegyzés!
Ha egy feladathoz előzőleg kiválasztott frissítési forrást később inaktívvá tesz, akkor a feladat a forrás újbóli aktiválásáig (kijelöléséig) nem működőképes, nem indítható.
A lehetséges frissítési források és beállításai a következők:
• HTTP
Frissítés HTTP protokollon keresztül. Meg kell adni a HTTP szerver nevét, a szerver által használt portot (alapértéke 80) és az útvonalat, ahol a leíró fájl található. Alapértelmezett beállítás: update.virusbuster.hu:80/pub2006
Amennyiben Proxy authentikáció is szükséges a szerver eléréséhez – az alapbeállításokat használva erre nincs szükség – úgy adja meg a Proxy felhasználó nevet és jelszót a rendelkezésre álló mezőkben.
• FTP
Frissítés FTP protokollon keresztül. Meg kell adni a használni kívánt FTP szerver nevét, a szerver által használt portot (alapértéke: 21), az útvonalat, ahol a leíró fájl található, valamint a szerverre bejelentkező felhasználó nevét és jelszavát. Amennyiben az ’Anonymous’ felhasználó nevet használja, akkor a Jelszó mezőbe a saját e-mail címét gépelje be. Alapértelmezett beállítás: anonymous@update.virusbuster.hu:21/pub2006
• NetWare útvonal
A programfrissítés Novell NetWare szerverről is elvégezhető, a kívánt útvonalat írja be a rendelkezésre álló mezőbe UNC-s formában (\\szervernév\megosztásnév).
• Útvonal
A programfrissítés végrehajtható helyi-, illetve hálózati meghajtóról is. Az útvonal a |...| gomb segítségével állítható be.
• CD meghajtó
Amennyiben a programfrissítés CD-ről történik, a legördülő listából válassza ki a CD meghajtó betűjelét.
Figyelem!
A helyi-, vagy hálózati útvonalról történő frissítés csak abban az esetben alkalmazható, ha a felhasználó bejelentkezett a tartományba!
A frissítés Novell NetWare hálózati útvonalról csak abban az esetben működik, ha a felhasználó bejelentkezett a szerverre!

A panel alsó részén megtekinthetők, módosíthatók, indíthatók, felfüggeszthetők az előzőleg felvett feladatok, és új feladatok felvételére is itt van lehetőség. A feladat listában a feladat neve látható az első oszlopban, utána az utolsó indítás időpontja jelenik meg, majd a következő indítás időpontja – előidéző eseménye – olvasható. Az utolsó oszlop jelzi azt is, ha fel van függesztve a feladat futása.
Az oldal alján a megfelelő gombokra kattintással a következő műveletek végrehajtására van lehetőség:
• |Új feladat|
Egyéni frissítési feladat létrehozása, a frissítési beállítások meghatározása.
• |Módosítás|
Egy kiválasztott feladat beállításainak megváltoztatása.
• |Törlés|
Egy kiválasztott feladat törlése.
• |Indítás|
A Feladatok ablakban kiválasztott feladat futtatása, végrehajtása.
• |Letiltás|
A kijelölt feladat futtatásának felfüggesztése: a feladat az újbóli engedélyezésig nem indul, nem indítható.

Új frissítési feladat felvitele

Egy feladat paramétereit lépésről-lépésre lehet beállítani, mely lépésekben a frissítési feladat tulajdonságait lehet meghatározni.

Termékek

Első lépésként ki kell jelölni az adott frissítési feladathoz kapcsolódó terméke(ke)t. Az itt megjelölt termék(ek) naprakészségét vizsgálja majd futása során az adott feladat, és ha létezik újabb változat a kijelölt termék(ek)ből, akkor letölti azokat, majd frissíti a rendszert. A lista a telepített termékeket és a vírusadatbázis fájlt tartalmazhatja, amelyek az előttük lévő jelölőnégyzetbe kattintással választhatók ki. Legalább egy elem kijelölése szükséges a frissítési feladat további beállításainak elvégzéséhez!

Ütemezés

A frissítési folyamat indítását ezen a panelen lehet időzíteni, azaz meghatározhatja, hogy az adott feladat mely kiválasztott időpontban, vagy esemény hatására hajtódjon végre.

A frissítési feladat indítása és futása a Felhasználó: paraméternél beállított felhasználói profilban meghatározott jogokkal hajtódik végre. A |Jelszó ...| gombra kattintással a bejelentkezéshez szükséges jelszó adható meg.
Egyszerűsített beállítások
A feladat indításának meghatározására kiválasztható időegységek a következők:
• naponta/hetente
A mérőszámmal megadható, hogy hány naponta illetve hetente hajtódjon végre a feladat. A feladat a szükséges napon a rendszerbe történő bejelentkezéskor hajtódik végre aktív hálózati kapcsolat esetén. Ha a feladat indítása nem sikerül, a program folyamatosan - bejelentkezéskor - megpróbálja elindítani a feladatot egészen addig, amíg az indítás sikeres nem lesz.
• kézi indítás
A feladat indítását a felhasználónak kell kezdeményezni, a feladat kijelölése után indítható a kívánt feladat.
Bővített beállítások
Részletesebb időzítési lehetőségekkel a következő beállítási formák állnak rendelkezésre a feladat ütemezésére:
• naponta/hetente
• kézi indítású
• időzített
Meg lehet határozni a feladat indításának pontos időpontját (óra, perc), majd kijelölni azokat a napokat, amelyeken a feladat a meghatározott időpontban végrehajtódjon.
• negyedóránként/félóránként/óránként
A feladat indítása a meghatározott időegységenként és napokon történik.

Frissítési források

Egyszerűsített beállítások
A legördülő listából kiválaszthatja a frissítési forrást, melyen a program a beállított időpontban, eseménykor megvizsgálja, hogy létezik-e újabb verzió a kijelölt termék(ek)ből. Csak az aktív frissítési források elérhetők, melyeket a Programfrissítő fő paneljén lehet beállítani az Engedélyezett frissítési források opcióban. A |Beállítások ...| gombra való kattintással a frissítési források beállításai globálisan megváltoztathatók.

Folyamatkijelző ablak engedélyezésekor a felhasználó figyelemmel kísérheti a frissítési folyamatot, ellenkező esetben ennek futása a háttérben történik.

Interaktív üzemmód engedélyezésekor, ha engedélyezve van a folyamatkijelző ablak megjelenítése, a felhasználó lépésről-lépésre figyelemmel kísérheti a frissítést, beavatkozhat a folyamatba, ideiglenesen megváltoztathatja a feladat beállításait.

A Gép újraindításának letiltása beállításban szabályozhatja a számítógép frissítés utáni újraindítását. Ha bejelöli a jelölőnégyzetet, akkor a számítógép újraindítására nem kerül sor a frissítés befejezése után.
Figyelem!
Kérjük csak indokolt esetben tiltsa le a számítógép újraindításának lehetőségét, hiszen ha a frissítés során olyan változás történik, melynél szükség van a számítógép újraindítására, és ez le van tiltva, akkor előfordulhat, hogy a gép állandó védelem nélkül marad!
Bővített beállítások
A bővített felületen az előbbi opciók mind megtalálhatók, illetve lehetőség van a Hálózati hozzáférés beállítás segítségével szabályozni a Programfrissítő hálózatkezelését a feladat indulásakor.

Amennyiben a Folyamatos hálózati kapcsolat beállítást választotta, az indított feladat nem kísérli meg létrehozni a hálózati kapcsolatot, és amennyiben mégsem lehet elérni a hálózatot: hibát generál. A Hálózati kapcsolat létesítése programfrissítéskor opció választása esetén, ha a hálózat nem állandóan elérhető – például modemes Internet kapcsolat esetén – a feladat kezdeményezni fogja a hálózati kapcsolat létrehozását, és a feladat lefutása után megszakítja azt, amennyiben ő kezdeményezte a kapcsolat létrehozását. A második opció aktiválja a Hálózati kapcsolat paraméterei beállításokat, ahol egy legördülő listából ki kell választani a használni kívánt hálózati profilt, majd meg kell adni az ehhez tartozó jelszót.

Feladat neve

A feladat nevének meghatározásához írja be a kívánt megnevezést a rendelkezésre álló szövegmezőbe. Az adott feladatra később a megadott névvel lehet hivatkozni a Feladatok panel Feladatok listaablakában. Nem lehet egyforma névvel két feladatot felvenni, és nem lehet a \ (backslash) karaktert használni a feladat nevében.

Összegzés

Ezen az összefoglaló panelen csoportosítva láthatók az előző lépésekben megadott beállítások, hogy át lehessen tekinteni a feladat paramétereit. Ha helyesek a beállítások, akkor a |Vége| gomb lenyomása után a feladat beállításai mentésre kerülnek. A |Vissza| gomb segítségével lehet rálépni az előző beállítási panelre. A |Mégsem| gomb hatására minden esetben visszaugrik a Programfrissítő fő paneljére, és a beállított opciók elvesznek (új feladat nem jön létre, a módosítások nem történnek meg).

Frissítési feladat módosítása

A feladat felvitelkor kitöltött beállítási panelokon ugyanolyan sorrendben végezheti el a módosításokat, mint ahogy azt az új feladat felvitelekor megtette.
• Összegzés
Első lépésben összefoglalva megtekintheti a feladat beállításait.
• Termékek
Módosíthatja a frissítésre kiválasztott termékek listáját (lásd Termékek panel leírása).
• Ütemezés
Megváltoztathatja a feladat indításának időzítését (lásd Ütemezés panel leírása).
• Frissítési forrás
Kiválaszthat egy új frissítési forrást a feladathoz (lásd Frissítési forrás panel leírása).
• Feladat neve
A feladat nevét nem tudja megváltoztatni, ez az egy beállítás, ami egyértelműen azonosít egy adott feladatot.
• Összegzés
A módosított beállítások megtekintése (lásd Összegzés panel leírása).

Frissítési feladat végrehajtása

Egy programfrissítő feladat – a beállításnak megfelelően – indulhat egy előre meghatározott időpontban (időzített), egy esemény hatására (rendszerindításkor), vagy a felhasználó maga indíthatja el.

A frissítő feladat egyes lépései nyomon követhetők, ha a feladat működése interaktív – ezt a feladat felvitelekor, vagy a paraméterek módosításakor lehet beállítani a Frissítési források panelen.
A feladat végrehajtási módját bármelyik lépésben automatizálhatja a panelok alján található Automatikus működés beállítás kiválasztásával, ilyenkor a frissítési lépéseket a program automatikusan végrehajtja, az Összesítés panelon aztán megtekintheti a frissítési folyamat futásának összegzését, értékelését.

A frissítési folyamat elején a program összegyűjti a frissítendő termékek, komponensek verzió adatait, majd ezeket összeveti a frissítési forrásként meghatározott helyen található termékek hasonló adataival, és ha a frissítésre szükség van (vannak újabb verziók a forrás-helyen), akkor ezeket először letölti a felhasználó számítógépére, majd frissíti a szükséges programokat, modulokat.

Interaktív működésben a frissítő műveletek végrehajtása nyomon követhető, a végeredményről szintén az Összesítés panelon tájékozódhat.

Előzetes

E menüpontban megjelennek az adott frissítési feladat főbb beállításai.
Figyelem!
A feladat lefutása előtt lehetőség van egyes beállítások módosítására, melyek az aktuálisan indított feladatra ideiglenesen lesznek érvényesek!

A Programfrissítő a Termékek ablakban megjelenő termékeket próbálja meg frissíteni. A listának két oszlopa van, az első a terméknevet, a második a termék méretét tartalmazza (MB-ban). Az első oszlopban megjelenített elemek mellett egy jelölőnégyzet található, mellyel a felhasználó ki tudja kapcsolni azokat a termékeket, amelyeket nem kíván frissíteni.

A panel alsó részén a fontosabb programbeállítások találhatók, a frissítési forrást megváltoztatható a |Beállítások ...| gombra kattintással. Ekkor egy új ablakban módosíthatja az egyes forrásokhoz tartozó paramétereket.

A program a feladat befejezése után szükség esetén újraindítja a számítógépet, a Számítógép újraindítása beállítás kijelölésével ez mindenképpen megtörténik.

A |Tovább| gombbal léphet a következő panelre, a |Mégsem|-mel megszakíthatja a frissítést.

Adatlekérdezés

E lépésben a Programfrissítő a kiválasztott elemekről szerez információt a frissítési forrásból. A felső ablakban látható(k) a frissítésre kijelölt összetevő(k), a panel alsó fele pedig az adatlekérdezés állapotáról és beállításairól tájékoztat.

Az Aktuális művelet folyamatjelző mutatja az információgyűjtés állapotát, megtekintheti a letöltési sebességet, a frissítési forrást és a letöltés helyét, ahová az információs fájlok átmenetileg letöltésre kerülnek.

Probléma esetén a |Tovább| gombra kattintás után az Összesítés panel nyújt bővebb információt a hiba okáról. Ha minden rendben lezajlott, a letöltés befejezése után a |Tovább| gomb a következő panelra vezet, a |Vissza| gomb az előzőre, a |Mégsem|-mel pedig megszakíthatja a frissítést.

Termékválasztás

E panelon módosíthatja a frissíteni kívánt termékek listáját a panel felső részén található Termékek ablakban.

A telepítendő program neve mellett a termék verziószáma, mérete, és a kalkulált letöltési idő látható.
Alul a Letöltés részben összesítve láthatók a következő információk:
• Letöltendő méret
A kiválasztott programkomponensek összesített mérete.
• Letöltés időtartama
Az összes összetevő letöltéséhez szükséges becsült időtartam.
• Letöltési sebesség
A letöltendő fájlok becsült letöltési sebessége.
Az automatikus működés itt is aktivizálható a jelölőnégyzet bejelölésével.

A letöltés befejezése után léphet a következő panelra a |Tovább| gombbal, az előző panelra a |Vissza| gombbal, a |Mégsem|-mel pedig megszakíthatja a frissítést.

Letöltés

A panel felső részén a Termékek ablakban láthatók a letöltendő termékek.
A termékek előtti kis CD ikonon egy jobbra mutató zöld nyíl jelzi, hogy éppen melyik van letöltés alatt, és ennek adatai, aktuális állapota látszik az alsó Letöltés részen. A sikeres letöltést zöld pipa megjelenése jelzi az ikonon. Piros felkiáltó jel mutatja, ha valami probléma van a letöltéssel, a hiba okáról a |Tovább| gomb megnyomása után az Összesítés panelon kaphat információt.

Ha a letöltés rendben lezajlott, akkor a |Tovább| gombbal a következő panelra léphet.

Letöltés összesítés

Sikeres fájlletöltés után egy összesítő képernyőn tekinthetők meg a letöltött programösszetevők verziószámmal, méretükkel.

Az ablak alsó részében egy információs szöveg tájékoztat arról, hogy a következő lépésben történik meg a kijelölt programok, komponensek frissítése.

A frissítési forrás alatt a számítógép újraindítási beállításának állapota látható, és áttérhet automatikus működésre a beállítás neve előtti jelölőnégyzetbe kattintással.

Telepítés

E lépésben történik meg a kiválasztott és sikeresen letöltött összetevők telepítése.

A termékek előtti kis CD ikon a fentiekben tárgyalt módon jelzi, melyik elem van éppen frissítés alatt, ennek aktuális állapotát a panel alján lévő folyamatjelző csík mutatja.

Frissítéskor a program a telepítés idejére leállítja az éppen futó alkalmazásait, és megtörténik a verziócsere. Ez több percet is igénybe vehet!

Továbblépni csak a frissítés befejezése, vagy esetleges hiba esetén lehet.

Összesítés

A frissítési folyamat utolsó állomása, a frissítési feladat hibátlan, vagy hibás lezajlásáról ad tájékoztatást. A folyamatot a |Befejez| gombbal zárhatja le.
Sikeres frissítés
Sikeres frissítés esetén, a panel tetején lévő ablakban láthatók a frissített alkalmazások az új verziószámmal és a frissítés dátumával. A panel alján statisztikát olvashat: a feladat végrehajtáshoz szükséges idő, és az összesen átmozgatott adatmennyiség látszik a képen.

Automatikus újraindítási beállítás esetén a panel tartalmaz egy folyamatjelzőt, mely jelzi az egy perces időtartamot, miután a számítógép automatikusan újraindul. Lehetőség van az újraindítás megszakítására, valamint az azonnali újraindításra is.
Sikertelen frissítés
Probléma esetén a panel alsó részén olvashat a hiba okáról, esetleges elhárításáról.
A Levélküldés a VirusBusternek jelölőnégyzet bejelölésével, a |Befejez| gombra kattintás után értesítést küldhet a hibáról a VirusBusternek, melyet munkatársaink elemezni fognak, és amint lehet, értesítik önt a probléma lehetséges megoldásáról.
Amennyiben az opció nem érhető el (nem lehet belekattintani a négyzetbe), állítsa be a levelezési beállításokat, melyek megléte elengedhetetlen a levél elküldéséhez!
Ha levelet kíván küldeni, ennek tartalmát és paramétereit a |Hibajelentés szerkesztése...| gombra kattintás után tekintheti meg. E panelon a feladó és címzett adatain kívül a levélhez csatolandó report.zip nevű fájl tartalmát is megtekintheti a |Tallóz ...| gombbal. Ez a tömörített fájl a hiba felderítéséhez, elemzéséhez szükséges egyéb adatokat tartalmazza.

Gyors vírusadatbázis-frissítés

A grafikus felhasználói felület főoldaláról (Információk menüpont) a |Frissítés| gombbal "gyors" adatbázis-frissítés kezdeményezhető (amennyiben létezik ez a funkció). Ilyenkor a program kiválaszt egy aktív frissítési forrást, ahonnan megpróbálja letölteni az adatbázis fájlt. A program mindig a legmagasabb szintű forrást választja az aktívak közül, és csak erről az egyről kezdeményezi a frissítést.
A frissítési források a következő lista szerint osztályozhatók (legmagasabb szinttől a legalacsonyabbig):
• Útvonal
• NetWare útvonal
• CD
• HTTP
• FTP


Kereső

A komponens keresési feladatok létrehozását, szerkesztését és eseti víruskeresés indítását teszi lehetővé. A feladatorientált működés lényege, hogy a felhasználó előre – saját maga által – meghatározott feladatok valamelyike alapján indíthat víruskeresést. A feladatokban a keresési módszer és a létező opciók már előzőleg beállítottak, így a keresési feladat kiválasztása után a kívánt paraméterű víruskeresés futtatása azonnal lehetséges. A keresési feladatok beállítása a Feladatok menüben történik, egyszeri keresés a Keresés indítása menüpont segítségével kezdeményezhető.

Feladatok

A Feladatok panelon az alapértelmezett és a felhasználó által felvett keresési feladatok egyaránt megtekinthetők, indíthatók, szerkeszthetők.
A Feladatok ablakban láthatók egymás alatt a rendelkezésre álló (indítható) feladatok. Kezdetben csak a három alapértelmezett feladat található itt, ezek a következők:
• Csak olvasható cserélhető eszközök vizsgálata
• Írható cserélhető eszközök vizsgálata
• Helyi merevlemezek vizsgálata
A panel jobb oldalán a Feladatok ablakban kiválasztott feladat tulajdonságai olvashatók, azaz az adott keresési feladat főbb beállításai jelennek meg. Ezek az adatok tájékoztató jellegűek, itt nem szerkeszthetők.
A feladatok típusát az előttük álló ikon jelzi, megkülönböztetésükre a következő jelölések használatosak:
A feladat valamely akcióra történő indítása (rendszerindítás).
A feladat indítását a felhasználó végzi (kézi indítás).
A feladat indítása egy meghatározott időpontban, vagy időközönként történik.
Az oldalon a megfelelő gombokra kattintással a következő műveletek végrehajtására van lehetőség:
• |Új feladat|
Egyéni keresési feladat létrehozása, a keresési beállítások meghatározása.
• |Módosítás|
Egy kiválasztott feladat beállításainak megváltoztatása.
• |Törlés|
Egy kiválasztott feladat törlése.
• |Indítás|
A Feladatok ablakban kiválasztott feladat futtatása, indítása.
A keresés folyamatát jelző keresőablak leírása a Víruskereső ablak fejezetben olvasható!

Új keresési feladat létrehozása

Az |Új feladat| gombra kattintva, a varázsló alapú felületen végighaladva, részletes leírások segítségével végezheti el az új keresési feladat hozzáadását. Az egyes paneleken elvégzett beállítások után a |Tovább| gombra kattintással léphet a következő beállítási szintre, a |Mégsem| gombbal megszakíthatja az új feladat felvitelét. A beállítások gyorsan és egyszerűen elvégezhetők az egyes szintek egyszerűsített paneljén, vagy részletesebben a szélesebb körű beállításokat lehetővé tevő bővített panelon, melyet az adott panel |Bővített| gombjára kattintással érhet el.
Keresési területek – a vizsgálni kívánt meghajtók beállítása
Egyszerűsített beállítások
A vizsgálni kívánt meghajtó-típusokat kiválasztásával meghatározhatja a keresési területeket, a víruskeresés csak a kijelölt meghajtó-típusokon kerül végrehajtásra. A továbblépéshez mindenképpen ki kell jelölni egy területet. A következő csoportok közül választhat:
• Cserélhető eszközök
Ezek az adathordozók könnyen eltávolíthatók a számítógépből (pl: floppy lemez)
• Helyi merevlemezek
Ezek közé a számítógépbe beépített háttértárolók számítanak (pl: winchester)
• Hálózati meghajtók
Távoli tárolók, melyek hálózaton keresztül érhetők el.
Bővített beállítások
A Bővített panelon be tudja állítani a vizsgálni kívánt meghajtókat, vagy akár csak egyes könyvtárakat.
A Keresési területek ablakban fa szerkezetben láthatók a számítógépen található lehetséges meghajtók és útvonalak. A könyvtárak előtti kis pluszjel jelzi, hogy a könyvtár tartalmaz alkönyvtára(ka)t. A pluszjel mínuszjelre vált, ha az adott könyvtár nyitva van, és látszanak az alkönyvtárai is. Egy könyvtárat kinyitni a névre való dupla-, vagy a pluszjelre való szimpla egérkattintással lehet. A könyvtárak előtti kis négyzet bejelölése jelenti az adott könyvtár kijelölését (a benne található fájlok át lesznek vizsgálva). Fontos, hogy nyitott, vagy zárt állapotban jelöl ki-, vagy vesz le kijelölést egy könyvtárról, mert nyitott állapotban, ha a főkönyvtár kijelölésre kerül, ez nem vonatkozik az alkönyvtáraira (nem rekurzív). Ez igaz a kijelölés megszüntetésére is. Zárt állapotban a kijelölés vonatkozik a kijelölt könyvtár összes alkönyvtárára is (rekurzív) és ez igaz a kijelölés megszüntetésére is. A rekurzívan kijelölt könyvtárak egy mellettük megjelenő csillaggal (*) vannak jelezve.

Hálózati számítógép esetén hálózati megosztásokat is felvehet ellenőrzésre a |Hálózat...| gomb segítségével. A megjelenő ablakban ki kell választani az ellenőrizni kívánt útvonalat, majd a |Hozzáad| gombbal hozzáadhatja a már meglévő útvonalak közé.
Beállítások – a keresés módjának meghatározása
Egyszerűsített beállítások

A keresés Alapértelmezett kiterjesztésekben beállítás kiválasztásakor a kereső az alapértelmezettként meghatározott fájltípusokat vizsgálja csak át. Ezek a fájltípusok a Kiterjesztések beállítása bekezdésben kerülnek ismertetésre.

Az összes fájl átvizsgálása a Minden fájlban opció kiválasztásával valósul meg. Ilyenkor – kiterjesztéstől függetlenül – az összes fájlon végrehajtódik a víruskeresés.
A továbbiakban a keres és irtás módja, a kereső működése állítható be előre definiált keresési fajták közül választva. A keresési fajták egyfajta beállítás-kombinációt jelentenek, melyek a Bővített panelra történő átváltáskor megjelennek a beállítások értékeként.
• Gyors ellenőrzés
Gyors víruskeresési módot használ, nem használ heurisztikus keresést, az irtható vírusokra a Meghagyás, a nem irthatókra szintén a Meghagyás műveletet alkalmazza. A folyamat működése automatikus, nem kíván felhasználói beavatkozást még esetleges vírustalálatkor sem. A beállított akciók hajtódnak végre a fertőzött fájlon.
• Interaktív ellenőrzés és eltávolítás
Alapos víruskeresési módot- és Közepes heurisztikát használ, az irtható vírusokra az Irtás, a nem irthatókra pedig a Karanténba mozgatás műveletet alkalmazza. Heurisztikus találatkor a művelet: Meghagyás. Felhasználói beavatkozás szükséges vírustalálatkor, meg kell erősíteni a meghatározott akciókat.
• Automatikus eltávolítás
Alapos víruskeresési módot- és Közepes heurisztikát használ, az irtható vírusokra az Irtás, a nem irthatókra pedig a Karanténba mozgatás műveletet alkalmazza. Heurisztikus találatkor a művelet: Meghagyás. A folyamat működése automatikus, a beállított akciók hajtódnak végre a fertőzött fájlon.
Bővített beállítások

A Minden fájl ellenőrzése beállításnál az összes típusú (kiterjesztésű) fájl ellenőrzésre kerül kereséskor.
Meghatározott kiterjesztések ellenőrzésekor csak a felhasználó által kiválasztott kiterjesztésű fájlok kerülnek ellenőrzésre. Az alapértelmezett értékek megváltoztatására, a keresésből kizárandó, és a keresésbe mindenképpen bevett fájlok meghatározására a |Kiterjesztések| gomb megnyomása után van lehetőség.
• Kiterjesztések beállítása
A következő fájltípusok vizsgálata valósul meg alapértelmezettként:
- Jet adatbázismotor fájlok
- Táblázatok
- Tömörített fájlok
- Dokumentum fájlok
- Power Point fájlok
- Program fájlok
- Script fájlok
Az ellenőrzésbe bevonhat, illetve kizárhat megadott fájltípusokat egyenként is. Ehhez csak engedélyezni kell az Ellenőrzésbe bevett fájlok vagy az Ellenőrzésből kizárt fájlok funkciót a jelölőnégyzetbe való kattintással, és a megfelelő mezőkbe begépelni az ellenőrzésbe bevenni- illetve kizárni kívánt fájltípusokat pontosvesszővel (;) elválasztva. (pl: *.rxx; *.qqq). Megadáskor használhatók joker karakterek (pl: *.qwe, *.?ab).
A Keresés tömörítvényekben jelölőnégyzet bejelölésével a program a tömörített fájlokat is átvizsgálja, a Memória ellenőrzése opció bekapcsolásakor pedig kereséskor először a memória tartalmát vizsgálja át a program, majd a meghatározott területeket.
A keresési mód a következő szinteken szabályozható:
• Gyors/Alapos/Teljes
Heurisztikus keresés beállítása a következő szinteken lehetséges:
• Kikapcsolva/Normál/Erős
A Találati beállítások részben határozhatja meg a vírustalálatkor végrehajtandó (automatikus mód), vagy felajánlott (interaktív mód) műveleteket. A kiválasztott elsődleges művelet a Vírustalálat esetén beállításban határozható meg. Amennyiben ez nem végrehajtható (pl. a vírus nem irtható), akkor a másodlagos művelet, a Sikertelen irtás esetén beállításban meghatározott kerül végrehajtásra/felajánlásra. Vírustalálat esetén, az irtás műveleten kívül alapvetően minden más művelet végrehajtható a fertőzött fájlon, ezért a másodlagos művelet beállításának nincs értelme – nem kell meghatározni – abban az esetben, ha az elsődleges műveletnél beállított érték az irtástól különböző. Lehetősége van még műveletet beállítani heurisztikus találat esetére is.
Választható műveletek Vírustalálat esetére:
• Irtás/Meghagyás/Átnevezés/Karanténba mozgatás/Törlés
Választható másodlagos művelet és beállítás heurisztikus találat esetén:
• Meghagyás/Átnevezés/Karanténba mozgatás/Törlés
Az Interaktív kommunikációt választva minden egyes incidens esetén a felhasználótól vár beavatkozást a program, és a beállított akciókat ajánlja fel alapértelmezettként. Ellenkező esetben a beállított akciók automatikusan végrehajtódnak a fertőzött fájlon.
Ütemezés panel – keresés időpontjának meghatározása
Egy keresési feladat ütemezésének – tehát a vírusellenőrzés megkezdésének – meghatározása könnyen elvégezhető a panelen. Számos időzítési beállítás közül választható ki a kívánt gyakoriság, vagy egy meghatározott időpont, esemény. Az időzítési paraméterek beállítása megegyezik a Programfrissítés fejezet Ütemezés pontjában leírtakkal.
Feladat neve
A feladat nevének meghatározásához írja be a kívánt megnevezést a rendelkezésre álló szövegmezőbe. A név megadása kötelező, különben a feladat felvitele nem fejezhető be.

A |Vége| gomb megnyomása után a programban létrejön az adott beállításokat tartalmazó kereső feladat, hivatkozni rá a megadott névvel lehet a Feladatok panel listaablakában. Nem lehet egyforma névvel két feladatot felvenni, és nem lehet a \ (backslash) karaktert használni a feladat nevében.

Keresési feladat módosítása

A feladat felvételkor kitöltött beállítási panelokon ugyanolyan sorrendben végezheti el a módosításokat, mint ahogy azt a feladat felvételekor megtette.
• Keresési területek módosítása
Módosíthatja a kiválasztott kereső feladat átvizsgálási célterületeit (lásd Keresési területek panel leírása).
• Beállítások – a keresés módjának meghatározása
Megváltoztathatja a keresési feladat beállításait (lásd Beállítások – a keresés módjának meghatározása panel leírása).
• Ütemezés
Az ütemezési beállítások változtatására van lehetőség (lásd Ütemezés panel leírása).
• Feladat neve
A feladat nevét nem tudja megváltoztatni, ez az egy beállítás, ami egyértelműen azonosít egy adott feladatot. A |Vége| gombbal visszatérhet a Feladatok panelra.

Keresés indítása

Amennyiben nem kíván feladatot meghatározni a kereséshez, csupán egy egyszerű víruskeresést kíván végrehajtani, a Keresés indítása menüpont segítségével könnyen és gyorsan meghatározhatja a szükséges beállításokat. A menüpont kiválasztása után a keresési területek megadása mindenképpen szükséges a vizsgálat megkezdéséhez, azután akár azonnal indítható a keresés az ablak alján található |Keresés| gombra kattintással (ilyenkor a nem megadott paraméterek alapértelmezett értékükön lesznek figyelembe véve). A kézi indítású keresés teljes konfiguráláshoz a következő beállítási lehetőségek állnak rendelkezésre:
• Keresési területek
Először meg kell határozni azokat a meghajtókat, melyeken víruskeresést szeretne végrehajtani. A panel funkciója és beállítása megegyezik az új feladat felvitelénél ismertetett Keresési területek panellal.
• Beállítások
Meghatározhatja, mely fájltípusok kerüljenek ellenőrzésre, továbbá beállíthatja a vírus találatkori akciókat. A panel működése megegyezik az új feladat felvitelénél ismertetett Beállítások pontjának működésével.
• Keresés indítása
E panelon megtekinthetők a főbb keresési beállítások és az |Indítás| gombbal indítható a keresés. A keresés folyamatát jelző keresőablak leírása a Víruskereső ablak fejezetben olvasható!


Gyorskeresés

A fájlok és könyvtárak vírusellenőrzése nem csak a felhasználói felületről és a tálcáról indítható, hanem a Windows rendszerben bárhol a helyi menük segítségével. A Sajátgépben egy egész meghajtót-, vagy az Intézőben egy könyvtárat, esetleg csak egyetlen fájlt is kijelölhet vírusellenőrzésre.
A kiválasztott egységen (meghajtó, könyvtár, fájl) a jobb egérgombra klikkelve megjelenik egy helyi menü, melyen a Keresés VirusBusterrel menüpontot kiválasztva megkezdődik a kiválasztott elem(ek) ellenőrzése. A keresés folyamatát jelző keresőablak leírása a Víruskereső ablak fejezetben olvasható!


MS Office védelem

A komponens a MS Office programcsomag alkalmazásait-, és az általuk használt fájltípusok védelmét látja el. A MS Outlook levelező kliens program védelmét külön komponens végzi.

A védelmi beállítások a Beállítások panelon végezhetők el. A MS Office védelem tulajdonságai beállíthatók az egyszerűsített panelon, vagy a szélesebb körű beállításokat lehetővé tevő bővített panelon, melyet a |Bővített| gombra kattintással érhet el.

Egyszerűsített beállítások

A védelem aktív, ha a Bekapcsolva jelölőnégyzet be van jelölve. Ezen kívül, a panelon előre definiált védelmi szintek közül választhat egyszerűen és gyorsan meghatározva a védelem erősségét. A védelmi szintek egyfajta beállítás-kombinációt jelentenek, melyek a Bővített panelra történő átváltáskor megjelennek a beállítások értékeként.
A védelmi szintek, és jelentésük:
• Erős
Teljes víruskeresési módot használ, az irtható vírusokra az Irtás, a nem irthatókra pedig a Karanténba mozgatás műveletet alkalmazza. Heurisztikus találatkor a művelet: Meghagyás.
• Közepes
Alapos víruskeresési módot használ, az irtható vírusokra az Irtás, a nem irthatókra pedig a Meghagyás műveletet alkalmazza. Heurisztikus találatkor a művelet: Meghagyás.
• Gyenge
Gyors víruskeresési módot használ, az irtható vírusokra az Irtás, a nem irthatókra pedig a Meghagyás műveletet alkalmazza. Heurisztikus találatkor a művelet: Meghagyás.
• Egyedi beállítások
A beállítás nem választható, akkor lesz kijelölve, ha a Bővített panelon olyan beállítás-kombináció jön létre, mely nem fedi le egyik előre definiált védelmi szint beállításait sem.

Bővített beállítási lehetőségek

A Bővített panelon a Védett alkalmazások ablakban beállíthatja az állandó védelemmel védeni kívánt alkalmazásokat úgy, hogy a kiválasztott alkalmazások előtti jelölőnégyzetet bejelöli. Az üres jelölőnégyzettel álló alkalmazásoknak nincs vírusvédelme.
A program és a felhasználó közötti kommunikációt, illetve annak szintjét állíthatja be a Kommunikáció szintje beállítással:
• Automatikus működés
A megadott beállításoknak megfelelően a védelem automatikusan elvégzi az akciókat, a kijelölt irtási műveleteket felhasználói beavatkozás nélkül elvégzi.
• Figyelmeztető üzenet megjelenítése
A megadott beállításoknak megfelelően a védelem elvégzi az akciókat, ezek megtörténtéről tájékoztatja a felhasználót.
• Interaktív kommunikáció
A felhasználó értesítést kap egy találat esetén, és eldöntheti milyen akció hajtódjon végre (alapértelmezetten a védelemi beállításoknak megfelelő akciókat ajánlja fel a program végrehajtásra).
A Találati beállítások leírását lásd a Kereső fejezet hasonló beállításánál! Választható műveletek Vírustalálat esetére:
• Irtás/Meghagyás/Átnevezés/Karanténba mozgatás/Törlés
Választható másodlagos művelet és beállítás heurisztikus találat esetén:
• Meghagyás/Átnevezés/Karanténba mozgatás/Törlés


MS Outlook védelem

A komponens a MS Outlook levelező kliens program védelmét látja el. A beállításoknak megfelelően ellenőrzi a beérkezett üzeneteket, valamint folyamatos védelmet nyújt a program futása során. A komponens beállítása elvégezhető a VirusBuster konzolon, a védelem teljes körű konfigurálásához a program MS Outlook kliensbe beépült modulját is be kell állítani.

VirusBuster konzol beállítások

A védelmi beállítások a következő panelokon végezhetők el:
• Beállítások
• Keresési beállítások

Beállítások

A védelmi beállítások a Beállítások panelon végezhetők el. A MS Outlook védelem tulajdonságai beállíthatók az egyszerűsített panelon, vagy a szélesebb körű beállításokat lehetővé tevő bővített panelon, melyet a |Bővített| gombra kattintással érhet el.
Egyszerűsített beállítások
A védelem aktív, ha a Bekapcsolva jelölőnégyzet be van jelölve. Ezen kívül, a panelon előre definiált védelmi szintek közül választhat egyszerűen és gyorsan meghatározva a védelem erősségét. A védelmi szintek egyfajta beállítás-kombinációt jelentenek, melyek a Bővített panelra történő átváltáskor megjelennek a beállítások értékeként.
A védelmi szintek, és jelentésük megegyezik az MS Office védelem modulban leírtakkal.
Bővített beállítási lehetőségek
Ha a vírusos csatolmányt tartalmazó levélek megnyitása engedélyezve van (be van jelölve a hozzá tartozó jelölőnégyzet), akkor a kliensben lehetővé válik a vírusos csatolmányt tartalmazó levelek tartalmának megtekintése. Ha ez az opció nincs engedélyezve, a vírusos csatolmányt tartalmazó levelek információ-tartalmának olvasása sem lehetséges.
A Találati beállítások leírását lásd a Kereső fejezet hasonló beállításánál! Választható műveletek Vírustalálat esetére:
• Irtás/Meghagyás/Csatolmány átnevezése/Karanténba mozgatás/Csatolmány törlése
Választható másodlagos művelet és beállítás heurisztikus találat esetén:
• Meghagyás/Csatolmány átnevezése/Karanténba mozgatás/Csatolmány törlése

Keresési beállítások

A panel a keresési és finomhangolási opciók beállítását teszi lehetővé.

Az Interaktív kommunikáció bejelölése esetén a felhasználó értesítést kap vírustalálat esetén, és eldöntheti milyen akció hajtódjon végre (alapértelmezetten a védelemi beállításoknak megfelelő akciókat ajánlja fel a program végrehajtásra). Ellenkező esetben a program vírustalálat esetén a beállított akciókat automatikusan végrehajtja, a felhasználó nem kap értesítést az incidensről.
A Keresés tömörítvényekben opció engedélyezése esetén a program a tömörített fájlokat is átvizsgálja vírusok után kutatva.
Az Automatikus keresés induláskor opció engedélyezésekor a védelem a MS Outlook minden egyes elindításakor elindítja a vírusellenőrzést, és a még ellenőrizetlen, új leveleken víruskeresést hajt végre.

Beállítások a MS Outlook kliensben

A program beállítási lehetőségeit a MS Outlook Eszközök/Beállítások menüpontján belül a MS Outlook védelem fülre kattintva érheti el.

Általános beállítások

A panelon néhány alapbeállítás és alapinformáció tekinthető meg.
Napló
A |Megtekintés| gombra kattintva a VirusBuster Napló komponensét érheti el, ahol megtekintheti a program különböző részeiből beérkező üzenetek.
Működés
A védelem kommunikációs szintjének beállítása:
• Interaktív működés
Kiválasztásakor vírustalálat esetén a rendszer a felhasználóhoz fordul további utasításokért.
• Automatikus működés
Ilyenkor a program nem kér megerősítést, hanem az érvényes beállítások szerint hajtja végre az akciókat.
Regisztráció
A regisztráció állapotát láthatja a panelnek ezen a részén. A |Regisztráció| gombra kattintva a megjelenő regisztrációs ablakban választhatja ki a regisztrálni kívánt VirusBuster terméket, adhatja meg a regisztrációs adatokat.
Vírusadatbázis
A vírusadatbázis verziószáma és dátuma. A |Frissít| gombbal aktualizálhatja az adatokat.

Keresési beállítások

Ezen a panelen állíthatók be a felhasználó által kezdeményezett ellenőrzések (beleértve az induláskori automatikus ellenőrzést is) paraméterei.
Keresési opciók
• Automatikus keresés induláskor
A kapcsoló engedélyezésével a rendszer az összes még nem ellenőrzött levelet ellenőrzi a MS Outlook minden indulásakor.
• Keresés tömörítvényekben
A kapcsoló engedélyezett állapota esetén a program a tömörített csatolt fájlokat is ellenőrzi.

Találati beállítások
A Találati beállítások leírását lásd a Kereső fejezet hasonló beállításánál! Választható műveletek Vírustalálat esetére:
• Irtás/Meghagyás/Csatolmány átnevezése/Karanténba mozgatás/Csatolmány törlése
Választható másodlagos művelet és beállítás heurisztikus találat esetén:
• Meghagyás/Csatolmány átnevezése/Karanténba mozgatás/Csatolmány törlése

MS Outlook állandó védelmi beállítások

Az Állandó védelem engedélyezett állapota azt jelenti, hogy a program abban az esetben ellenőriz, amennyiben levélhozzáférés (olvasás, írás) történik. A továbbiakban az ilyen esetben beállítható víruskeresési opciók kerülnek ismertetésre:
• Keresés tömörítvényekben
A jelölőnégyzet engedélyezett állapota esetén a program a tömörített csatolt fájlokat is ellenőrzi.
• Fertőzött levél megnyitásának tiltása
Kiválasztásakor a rendszer nem engedi megnyitni a levelet mindaddig, amíg a levél fertőzött csatolt fájlt tartalmaz.
• Fertőzött csatolmány megnyitásának tiltása
Kiválasztásakor a rendszer nem engedi megnyitni a csatolt fájlt mindaddig, amíg az vírusos.
• Fertőzött fájl beillesztésének tiltása
A jelölőnégyzet engedélyezett állapota esetén a program nem engedi, hogy egy levélhez fertőzött fájlt csatoljon.
Ellenőrizendő műveletek beállítása:
• Kapott üzenetek
A kapcsoló engedélyezett állapota esetén a program ellenőrzi a beérkező leveleket.
• Küldött üzenetek
A kapcsoló engedélyezett állapota esetén a program ellenőrzi az elküldött leveleket.
• Megnyitott üzenetek
A kapcsoló engedélyezett állapota esetén a program ellenőrzi a megnyitott leveleket.
• Módosított üzenetek
A kapcsoló engedélyezett állapota esetén a program ellenőrzi a módosított leveleket. Módosításnak számít egy levél újraküldése.
• Beszúrt csatolmányok
A kapcsoló engedélyezett állapota esetén a program ellenőrzi a levélírás közben beillesztésre kerülő fájlt (csatolmányt).
A Találati beállítások részben ugyanazokat a beállításokat választhatja ki, mint a Keresési beállítások panel Találati beállítások részénél.

Keresés végrehajtása leveleken

A MS Outlook Eszközök/Teljes keresés vagy Eszközök/Kiválasztott elemek ellenőrzése menüpontok kiválasztásával keresést hajthat végre a teljes-, illetve a kijelölt leveleken.
A keresés folyamán megjelenő víruskeresési ablak a következő információkat tartalmazza:
• Víruskeresési adatok
Itt kerülnek megjelenítésre az ellenőrzött levelek száma, a vírustalálatok száma, gyanús állományok, megtisztított csatolmányok, és a legutóbbi vírustalálat.
• Ellenőrzési adatok
Tájékoztatást ad a víruskeresés helyéről (mappa), a vizsgált levél feladójáról és esetleges tárgyáról.
• Napló adatok
A talált vírusok listája kerül megjelenítésre.
A keresés végeztével az ablak automatikusan bezáródik, amennyiben nem volt vírustalálat. Vírustalálat esetén az |OK| gombbal zárható be az ablak.


Karantén modul

A komponens feladata – beállításoktól függően – a nem irtható vírusos fájlok tárolása és azok további feldolgozása. A karantén beállítások a következő panelokon végezhetők el:
• Bejegyzések
• Beállítások

Bejegyzések

A Bejegyzések lista információt nyújt az összes karanténba helyezett fájlról.
A következő adatok kerülnek megjelenítésre a karantén ablakban:
• Név
A fájl eredeti neve
• Eredeti útvonal
A fájl karanténba kerülés előtti helye a rendszerben.
• Vírus neve
A fájlban található irtható vagy nem irtható vírus neve.
• Bekerülés dátuma
A karanténban található fájlokon számos akció hajtható végre, melyeket a panel alján elhelyezett gombokkal aktivizálhat:
• |Újraellenőrzés|
A program ismételt vírusellenőrzést hajt végre a kijelölt fájlo(ko)n, illetve kiirtja a vírust, amennyiben ez lehetséges.
• |Visszaállítás|
A program visszaállítja a fájlt eredeti helyére és állapotába, amennyiben a Vírusos fájlok visszaállítása funkció engedélyezve van a komponens Beállítások paneljén (csak ha vírusos a fájl), az eredeti útvonal létezik és nem található az útvonalon azonos nevű fájl. Ha az eredeti útvonalon található egy azonos nevű fájl, illetve az útvonal nem létezik, a karantén a fájlt a program ideiglenes könyvtárába állítja vissza.
• |Mentés mint...|
A fájlt a megadott néven menti el. A program a fájlt kódolja, hogy a vírus ne legyen aktív és a fájl küldhető legyen víruselemzésre.
• |Küldés|
A kiválasztott fájl(oka)t elküldi a VirusBuster címére elemzésre. A gombra kattintás után a Levelező komponens ablakban fejezheti be az üzenet elküldését.
• |Törlés|
A program véglegesen törli a kijelölt fájl(oka)t.
• |Frissítés|
Karantén elemek listájának újrarajzolása.

Beállítások

A karantén működésére vonatkozó egyéb beállítások meghatározása e panelon lehetséges.
A Vírusos fájlok visszaállítása opció segítségével engedélyezhető a karantén visszaállítás funkciójának használata vírusos fájlok esetén, a |Visszaállítás| gomb aktív ekkor aktív a Bejegyzések panelon.
• Automatikus újraellenőrzés vírusadatbázis frissítése után
Ha az opció engedélyezve van, a program minden vírusadatbázis frissítés után újraellenőrzi a karanténban található fájlokat, illetve kiirtja az azokban található vírusokat, ha ez lehetséges.
• Irtható vírusok automatikus irtása
Engedélyezése esetén a vírusadatbázis frissítés után irthatóvá vált vírusokat a program automatikusan irtja a karanténban található fájlokból. A funkciót csak akkor lehet beállítani, ha az Automatikus újraellenőrzés vírusadatbázis frissítése után funkció engedélyezve van.
• Megtisztított fájlok automatikus visszaállítása
Engedélyezése esetén a program automatikusan visszaállítja mindazon fájlokat, melyeket a vírusadatbázis cseréje után a program automatikusan megtisztított. A funkciót csak akkor lehet beállítani, ha az Automatikus újraellenőrzés vírusadatbázis frissítése után opció engedélyezett.
Megjegyzés!
Karantén könyvtár meghatározására nincs szükség, a program automatikusan a telepítési könyvtár Quarantine alkönyvtárát használja karantén könyvtárként.


Napló komponens

Fő feladata a program különböző részeiből (moduljaiból) beérkező üzenetek tárolása és azok eljuttatása a felhasználóhoz.
A bejegyzések megtekintése, és a lehetséges beállítások a következő menüpontokban végezhetők el:
• Bejegyzések
• Beállítások

Bejegyzések

A napló-üzenetek segítségével nyomon követheti a vírusvédelem működését, megtudhatja az esetleges hibák keletkezésének okát, és megtekintheti az egyéb programüzeneteket.
A Napló bejegyzések ablakban a következő információk jelennek meg:
• Modul
A bejegyzést létrehozó modul neve.
• Dátum
Az üzenet keletkezésének időpontja.
• Gép
Annak a számítógépnek a neve, melyen keletkezett az üzenet.
• Felhasználó
A felhasználó neve, aki elindította az alkalmazást, mely az üzenetet generálta.
A program automatikusan frissíti a listát, ha új üzenet keletkezik, vagy törlődik. A frissítés nem módosítja az éppen kijelölt elemet, feltéve, ha nem éppen azt törölték a listából.
A lista-ablakban jobb egérgomb kattintásra megjelenik egy helyi menü, melyben lehetőség van az üzenetek egyes mezőinek ki-, illetve bekapcsolására – az oszlop nevére való kattintással –, és a következő műveletekre:
• Napló mentése...
Az üzenet tartalmának kimentése egy meghatározott fájlba.
• Küldés...
Üzenet, és a napló fájl küldése a VirusBuster támogatásnak. Kiválasztása után a Levelező komponens ablakban fejezheti be az üzenet elküldését (ha telepítve van).
• Újratölt
A lista frissítése.
• Törlés
Az !összes! üzenetek törlése a listából.
Ha egy bejegyzésre duplán kattint, megjelenik az üzenet részletezése, és így megtekintheti annak teljes tartalmát!

Beállítások

E panelon a bejegyzések megjelenítésének, és kezelésének paramétereit állíthatja be.
Meghatározhatja a naplóbejegyzések megjelenésének időrendi sorrendjét a megfelelő választógomb kiválasztásával, és korlátozhatja a napló-adatbázis méretét:
• Naplóüzenet tárolása a rendszerben
A beállított értéknél (nap) régebbi bejegyzések automatikus törlése az adatbázisból.
• Adatbázis méretének korlátozása
Kérheti a napló-adatbázis méretkorlátozását is, meghatározhatja a maximális méretet (MBájt), és a régi üzenetek folyamatos törlésével a program fenntartja a kívánt méretet.


Adminisztráció

Az Adminisztráció menüpontban lehetősége van letiltani a védelem egyes beállításainak módosíthatóságát, illetve a program működését befolyásoló egyéb opciók is rendelkezésére állnak, melyekkel teljesen testre szabhatja a védelmi rendszer működését. A panelhez és beállításokhoz való hozzáférést a rendszergazdák jelszóval védhetik le, mellyel biztosítani lehet, hogy csak az arra jogosult személy tudja módosítani az ebben a menüpontban található beállításokat, illetve a védelem kiemelt beállításait.

Az Adminisztrációs panelra kattintás után – ha már van beállított jelszó – meg kell adnia jelszavát, hogy hozzáférjen az adminisztrációs beállításokhoz, illetve módosítani tudja a program zárolt opcióit. Gépelje be jelszavát a Jelszó mezőbe, majd kattintson a |Rendben| gombra az adminisztrációs beállítások eléréséhez (Adminisztrációs mód).

Amennyiben nincs még beállított jelszava, akkor a program összes beállítása módosítható a felhasználók által. Jelszavát a Hozzáférési beállítások panel |Jelszó megadása| gombjára kattintással állíthatja be.
Attól függően tehát, hogy a termékhez van-e jelszó beállítva, illetve be van-e jelentkezve a felhasználó ezzel a jelszóval, vagy nincs, alapvetően kétfajta működési mód érhető el:
• Adminisztrátor mód, miután az Adminisztráció panelen a felhasználó a jelszó megadása után bejelentkezett (ezt a navigációs gombok melletti kis lakat nyitott állapota is jelzi).
• Normál mód, amikor az Adminisztráció panel eléréséhez nem kell jelszót megadni, illetve nem történt még meg a beállított jelszóval a bejelentkezés (ilyenkor nem látható lakat a navigációs gombok mellett, illetve utóbbi esetben a lakat zárt állapotban látható).

Hozzáférési beállítások

Ha még nincs jelszó beállítva a termékhez, csak a |Jelszó megadása| aktív a panelon, amelyre kattintással beállíthatja jelszavát. A jelszó beállítása után egyes víruskeresési opciók csak e beállított jelszó megadása után lesznek módosíthatók (Adminisztrátor módban), így ezek értékeit csak az arra jogosult felhasználó tudja módosítani.
Ha beállította adminisztrációs jelszavát, a következő opciók érhetők el ezen a panelon:
• Jelszó módosítása
• Kijelentkezés
• Jelszó törlése

Általános beállítások

A különböző funkciók engedélyezésével, tiltásával a program általános működését szabályozhatja.
A Tálca beállítások segítségével testre szabható a Tálca menü működése, és a felugró ablakok megjelenítése.
• Tálca menü tiltása
Ha kijelöli ezt a tiltó opciót, akkor a Tálcán a VB ikonon jobb egérkattintásra nem fog megjelenni a helyi menü.
• Tálca ikon tiltása
Ennek hatására a VB Tálca ikon meg sem jelenik a tálcán.
• Felugró ablakok tiltása
A program nem fog – a tálca fölött közvetlenül megjelenő – felugró ablakokban információt megjeleníteni a működés közben keletkező problémákról, eseményekről. A programban használatos többi információs ablak (vírustalálat jelzése, figyelmeztető üzenetek) megjelenését ez a beállítás nem befolyásolja.

Az Egyéb beállítás csoportban található opció segítségével – ha ezt biztonsági okokból meg szeretné tenni – le tudja tiltani a Súgó fájl használatát. Ebben az esetben nem lesz elérhető a Súgó a program felhasználói felületéről.

A Nyelv csoportban a program nyelvezetét módosíthatja a lenyíló listában rendelkezésre álló nyelvek kiválasztásával. Egy új nyelv megadása után újra kell indítania a programot, hogy a módosítás érvényre jusson. A Tálcán lévő VB ikon nyelvezete csak a számítógép újraindítása után fog az új beállításra változni.

Levelező beállítások

A menüpont csak akkor jelenik meg, ha a Levelező komponens telepítésre került. A termékből történő levélküldéshez meg kell adnia a levelezéssel kapcsolatos beállításokat. A VirusBusternek tudnia kell, hogy milyen csatornákon keresztül tudja elküldeni az üzeneteket, ezért szüksége van a levelezési paraméterekre. A szükséges paraméterek leírását a Levélküldés fejezetben olvashatja részletesen.

Központi értesítő

A Központi értesítővel lehetőség van meghatározott típusú üzenet keletkezése esetén értesítést küldeni egy megadott e-mail címre – például a rendszergazdának – a rendszerben történt eseményekről.

Az Üzenet-továbbítás funkció kiválasztásával kapcsolhatja be a központi értesítőt. Alább válassza ki azokat az üzenettípusokat, melyek keletkezésekor szeretné, hogy a modul értesítést küldjön a megadott e-mail címre. Az üzenettípusok a következők:
• Vírustalálat (*)
Vírusfertőzött fájl találata esetén keletkezik.
• Gyanús fájl
Gyanús fájl találata esetén keletkezik.
• Konfiguráció-változás (*)
Ha a termék beállításai, konfigurálása módosul.
• Kivétel megsértés esetén
Kivétel megsértés probléma megtörténtekor keletkezik.
• Figyelmeztetés
Akkor keletkezhet, ha nem fut valamelyik komponens, valamelyik folyamat közben kisebb hiba történik, egyéb.
• Nyugtázás
Valamely művelet, feladat végrehajtásáról, megtörténtéröl szóló üzenet.
• Üzenet
Tájékoztató jellegű információ a rendszer működésével kapcsolatban.
• Hiba
Valamely feladatot, műveletet nem sikerült végrehajtani, nincs beállítva, stb.
• Kritikus hiba (*)
A termék működésében komoly hiba történt.
• Biztonság (*)
Vírusadatbázissal kapcsolatos probléma merült fel, pl: a verzió nem megfelelő (régi), egyéb biztonsággal kapcsolatos figyelmeztetések.
A képernyő alsó részén található mezőbe egy e-mail címet kell megadni, ahová a rendszer küldeni fogja az üzeneteket. A |Tallóz ...| gomb segítségével levelezőprogramja címjegyzékéből választhatja ki az e-mail címet.

Az Üzenetrészletezés küldése beállítás kiválasztásával a rendszer által küldött üzenet részletesebb magyarázatot ad a probléma, esemény bekövetkezéséről – amennyiben ilyen részletező leírás a rendelkezésre áll.

Jogosultsági beállítások

Ebben a menüpontban részletesen meg lehet határozni, hogy az egyes modulokhoz milyen jogosultsággal (elérés, módosíthatóság) férjenek hozzá a terméket használók. A hozzáférés, illetve módosíthatóság attól függően állítható be, hogy adminisztrátorként (Adminisztrátor módban), illetve nem bejelentkezett felhasználóként (Normál mód) használják a terméket.
Figyelem!
Az Adminisztrátor módnak nincs köze a Windows rendszerbe bejelentkezett felhasználóhoz rendelt jogosultsági beállításhoz, ebben az esetben az Adminisztrátor mód a vírusvédelmi termékben megkülönböztetett magasabb szintű felhasználót jelenti!

Lehetőség van egyes műveletek (pl: feladatindítás) korlátozására, illetve akár egy teljes modul beállításainak módosítás elleni zárolására.

A panel középső részén található ablak első oszlopában találhatók a feltelepített komponensek (Komponens), melyekhez a hozzáférési, módosíthatósági beállításokat egy lenyíló listából választhatja ki a jobb oldali oszlopban (Hozzáférés)
Az egyes modulokhoz rendelhető hozzáférési beállítások a következők lehetnek:
• Rejtett
A modul nem lesz elérhető sem adminisztrátor módban, sem normál módban, amíg ez a beállítás van rendelve hozzá.
• Adminisztrátorként látható
A modul beállításai csak adminisztrátor módban érhetők el (normál módban nem), de a beállítások módosítására még adminisztrátor módban sincs lehetőség, amíg ez a beállítás van a modulhoz rendelve.
• Adminisztrátorként látható és módosítható
A modul beállításai csak adminisztrátor módban érhetők el (normál módban nem), a beállítások adminisztrátor módban szabadon módosíthatók.
• Mindig látható, de nem módosítható
A modul beállításai adminisztrátor- és normál módban egyaránt elérhetők, azonban egyik módban sem módosíthatók.
• Mindig látható, csak adminisztrátorként módosítható
A modul beállításai adminisztrátor- és normál módban egyaránt elérhetők, adminisztrátor módban módosíthatók is.
• Nincs korlátozás
Figyelem!
Ha a termékben nincs jelszó beállítva, akkor csak a Rejtett érték kiválasztásának van hatása, a többi lehetőség megadása esetén – mivel azok jogosultsághoz kötődnek – nem történik semmi.
Ha a Kereső, vagy a Programfrissítő modul hozzáférése korlátozva van, akkor adott esetben a modulok korábban felvett kereső, illetve frissítő feladatai sem érhetők el, nem lehet őket kézi indítással elindítani (az időzített feladatok természetesen működnek). A Feladatot indíthat beállításban megadhat egy kategóriát, melybe tartozó felhasználók képesek lesznek a korlátozások mellett feladatok indítására kézi indítással is:
• Mindenki
Adminisztrátor-, illetve normál módban lévő felhasználó egyaránt tud feladatokat indítani kézi indítással.
• Bejelentkezett adminisztrátor
Csak adminisztrátor módban lévő felhasználó tud feladatokat indítani kézi indítással, ha az indítás egyébként tiltva van.
• Senki
Nincs lehetőség a feladatok kézi indítására, ha az indítás egyébként tiltva van.

Aktiváció

Az Aktiváció menü abban az esetben érhető el, ha a termék regisztrációja aktiváció útján történt. Ebben az esetben itt tudja megtekinteni aktivációs adatait, szükség esetén itt aktiválhatja újra a terméket, változtathatja meg aktivációs adatait és kommunikációs probléma esetén az aktovációhoz szükséges hálózati beállításokat.

A lap alján található |Aktiválás...| gomb segítségével tud aktivációs folyamatot indítani. Aktivált termék esetén ennek akkor van jelentősége, ha aktivációs adatai megváltoztak (elsősorban az e-mail cím), illetve a termék regisztrációja lejárt, és újraaktiválás útján szeretné ismét regisztrálni. A gomb mellett az éppen aktuális aktiváltsági-státusz látható.

Aktivációs adatainak módosításakor egy meg kell adnia az új e-mail címet és/vagy az új aktivációs kulcsot, majd az említett |Aktiválás...| gombra kattintással indíthatja az aktivációt. Sikeres (újra)aktiváció esetén a megváltozott adatok elmentésre kerülnek, a termék a megadott aktivációs kód szerint lesz regisztrált.

Sikertelen aktiváció esetén, ha a probléma feltehetően a kapcsolati beállításokban van, akkor a proxy beállítások módosításával a probléma megoldható. A következő beállítások állnak rendelkezésre:
• Proxy nélküli Internet kapcsolat
Nem használ proxy-t.
• Rendszerbeállítások Internet-beállítások használata
Az operációs rendszerben beállított általános proxy beállítás használata.
• Kézi proxy-beállítások
Felhasználó saját maga állítja be a proxy címet és a hozzá tartozó port-ot.
Figyelem!
Az alapértelmezett proxy beállítások megváltoztatását csak nagy tapasztalattal rendelkező felhasználóknak ajánljuk!


Levélküldés

A programban lehetőség van közvetlenül üzenetet küldeni a VirusBusternek, ha valami kérdése, kérése van, azt könnyen eljutathatja hozzánk e formában.

A Levelező komponens elérhető a tálcáról (a VB ikonra való jobb egérkattintással válassza ki a Támogatás/Forduljon hozzánk menüpontot), továbbá a Napló vagy Karantén komponensekből.
Napló küldése
A napló fájl, vagy karanténból kiválasztott elemek beküldésekor megjelenő tájékoztató ablak felső részén láthatók a feladó adatai. Ezek a felhasználó által megadott, megadható adatok, szerkesztésük – az SMTP beállításokkal együtt – a |Levelezési beállítások ...| gombra kattintással lehetséges. A megjelenő panelon a következő adatok kitöltése szükséges (a helyes SMTP adatok megadása elengedhetetlen a levelező működéséhez):
• SMTP szerver
A levelező szerver neve, amely az e-mail kézbesítését végzi: a szolgáltatójának szervere, illetve vállalati környezetben az Exchange szerver neve (ez az információ megtalálható a levelező program /Outlook, Thunderbird stb./ beállításai között, vagy forduljon a rendszergazdához, esetleg a szolgáltatóhoz).
• Portszám
A levelező szerver portszáma (általában 25).
• Felhasználó neve
Az ön neve, ez a név fog szerepelni abban az e-mailben amit elküld nekünk. Ebben a mezőben tokenek is használhatók, melyek a következő értékeket jelentik:
%m% - számítógép neve
%u% - felhasználó neve
• E-mail cím
Az ön e-mail címe, erre a címre fogja megkapni a választ.
A panel közepén a Levél információk részben megtekinthető – de nem szerkeszthető – az elküldendő levél fejléce. Címzett a VirusBuster támogatási részlege, alatta a levél tárgya olvasható, majd a levélhez csatolt dokumentumok: napló küldése esetén a csatolt naplófájl neve, karantén küldése esetén a csatolt fájlokra való hivatkozás. A Megjegyzés részben ki kell töltenie a szöveg mezőt, melyben megírhatja nekünk a levél küldésének okát, kérdéseit, megjegyzéseit.

A levelet a |Rendben| gomb megnyomásával küldheti el ténylegesen, illetve a |Mégsem| gombbal megszakíthatja a folyamatot.


Víruskeresési módok

A keresőmotor a beállításoknak megfelelően különböző módon/szinten képes felderíteni és azonosítani a vírusokat. A programban lehetőség van komponens szinten választani a különböző keresési módok közül. A kiválasztható szintek a következőkben különböznek egymástól:
• Gyors
Szigorúan csak a fájl azon részeiben keres vírust, ahol az előfordulhat, néhány olyan vírustípust nem ismer fel, melyek megkeresése nagy erőforrást igényel (pl.: Excel FORMULA vírusok)
• Alapos
Optimalizált keresési mód, mely minden – az adatbázisban regisztrált – vírust felismer, a fájl azon részeiben keres vírust, ahol az előfordulhat.
• Teljes
Minden – az adatbázisban regisztrált – vírust felismer, a teljes fájlt leellenőrzi, azokat a részeket is, ahol normális esetben nem fordulhat elő vírus.


Heurisztika

Heurisztikus kereséskor a program megpróbálja felismerni az adatbázisában nem regisztrált, vírusokra jellemző tulajdonságokkal bíró kódrészletet, programot. Ha talál ilyen vírusgyanús fájlt, azt jelzi a felhasználónak. A heurisztikus keresés erősségi szintjének beállítása:
• Kikapcsolva
Nincs heurisztikus keresés.
• Normál
Limitált a vizsgálat mélysége, kicsi a vakriasztások valószínűsége, de az ismeretlen vírusokat is kisebb valószínűséggel azonosítja.
• Erős
Nagyobb valószínűséggel azonosít ismeretlen vírusokat, de a vakriasztások valószínűsége is nagyobb.


Akciók

Vírustalálatkor a fertőzött fájlon különböző akciók hajthatók végre. Az egyes műveleteket kiválasztva a következő hatást érheti el:
• Irtás
Vírus eltávolítása a fertőzött fájlból, a fájl vírusmentesen megmarad.
• Karanténba mozgatás
A fertőzött fájl karantén könyvtárba mozgatása. A karanténba került vírusok működésképtelenné válnak ezen az elkülönített helyen, nem jelentenek veszélyt a rendszer számára.
• Meghagyás
Figyelmen kívül hagyja az incidenst, az aktuális fájllal nem történik semmi.
• Törlés
A fertőzött fájl törlése.
• Átnevezés
A fertőzött fájl kiterjesztésének első betűjét v-re állítja.
A levélhez fűzött csatolmányokon végrehajthatók még a következő műveletek is:
• Csatolmány törlése
A fertőzött csatolmány eltávolítása a levélből.
• Csatolmány átnevezése
A fertőzött csatolmány kiterjesztésének első betűjét „w” –re nevezi át a program.


Ablakok, üzenetek

A VirusBuster üzeneteit, információit üzenet-ablakokban jeleníti meg a képernyőn, így tájékoztatja a felhasználót az esetleges vírusokról, vagy a rendszerben előforduló különböző eseményekről.

Víruskereső ablak

Víruskeresés indulásakor a keresés folyamatát és paramétereit jelző ablakból tájékozódhat a keresés aktuális állapotáról.
Víruskereső ablak
Az ablak felső harmadában a kereső folyamat fontosabb beállításai, a keresés és irtás módja látható. A Keresési folyamat részben látható mindig az aktuálisan vizsgált fájl az útvonalával, és a keresésből eltelt idő óra:perc:másodperc és egy folyamatjelző csík formában. A Keresési statisztika mutatja az eddig leellenőrzött fájlokat mennyiségét (Ellenőrizve), a vírusos (Fertőzött) és a vírustalanított (Megtisztított), valamint a vírusgyanús (Gyanús) fájlok számát. Az utolsó vírustalálatról az Utolsó találat – ahol az utolsó vírusos fájl és útvonala látható – és a Vírus neve mezők nyújtanak információt. A keresési folyamat alatt keletkező napló üzenetek a panel alsó részében elhelyezkedő ablakban olvashatók. Az egyes bejegyzésekre való dupla kattintással részletesebb információ jelenik meg az üzenetről.
Víruskeresés több módon is indítható, így a megjelenő keresési ablakok alapvetően ugyanazokat az információkat jelenítik meg, azonban kisebb eltérések megfigyelhetők a különböző módon indított keresési ablakok között. A fent említett általános információk mindig megjelennek a víruskereső ablakban, az egyéb megjelenített beállítások, és a rendelkezésre álló gombok választéka a víruskereső ablak indításától függ.

Víruskereső ablak keresési feladat indulásakor és kézi kereséskor

E keresési formák indítása esetén a víruskereső ablak nem külön ablakként, hanem a konzol felületen látható. Az alapinformációkon kívül a keresés szabályozására a következő gombok állnak rendelkezésre:
A |Mégsem| gombra kattintással bármikor megszakíthatja a keresést és visszatér a keresési Feladatokhoz.
Keresés ideje alatt:
• |Leállítás|
E gombbal megszakíthatja a keresést bárhol a folyamat során. Leállítás után az egyébként a keresés befejezése után megjelenő gombsorból választhat.
• |Felfüggesztés|
A keresés felfüggesztése esetén a keresés leáll, de nem végleg, a megjelenő |Folytatás| gombra kattintással a keresés ugyanabból a pozícióból folytatható.
Keresés befejezése után:
• |Újraellenőrzés|
A keresési feladat újbóli elindítása.
• |Mentés mint ...|
A keresésre vonatkozó napló üzenetek fájlba történő mentése.
• |Hozzáad| (csak Kézi indítású keresés esetén!)
A beállított paraméterekkel végrehajtott keresés egy új – később egy gombnyomásra elindítható – keresési feladatként elmenthető. A meghatározott beállításokon kívül már csak az Ütemezés és a Feladat neve lépéseket kell elvégezni az új feladat létrehozásához.

Víruskereső ablak gyorskeresés indításakor

Gyorskereséskor a képen látható ablak jelenik meg, tájékoztatja a felhasználót a keresés állapotáról. A panel alján látható még az Ablak automatikus bezárása a művelet végén jelölőnégyzet, melynek bejelölésével a keresés végeztével a keresőablak automatikusan bezáródik; ez egyébként a |Bezár| gombbal végezhető el. A keresés menet közbeni leállítása a |Keresés vége| gombbal lehetséges.

Üzenet ablakok

A program üzenet ablakai tájékoztatnak az esetleges vírusincidensekről, a felhasználók által kezdeményezett műveletek hatásáról, illetve a rendszerben felmerülő egyéb működési problémákról.

Vírusfertőzés felismerése

Víruskeresés folyamán, vírusos fájl esetén a program üzenet ablakban tájékoztat a fertőzésről.
A fertőzöttség típusai:
• Vírusos – irtható
A víruskereső motor vírusos fájlt talált, melyből a vírus eltávolítható.
• Vírusos – nem irtható
A víruskereső motor felismerte a vírust a fájlban, de adatbázisában nem áll rendelkezésre információ az eltávolítás módjáról.
• Gyanús
A víruskereső motor vírusgyanús fájlt talált. Ez azt jelenti, hogy a fájlban olyan kód, vagy kódrészlet található, mely vírus jelenlétére utal. Erről bővebben a Heurisztika részben olvashat!
Vírustalálati ablak a következő modulok működése közben jelenhet meg (amennyiben a modul elérhető a termékben):
• Keresési feladat, gyorskeresés végrehajtása közben
• Aktív állandó védelem esetén (nem interaktív)
• Aktív tartalomszűrő esetén
• MS Office védelem működése közben
• MS Outlook védelem működése közben
• Karantén tartalmának újraellenőrzésekor
E modulok mindegyikéhez külön Találati beállítások rendelhetők, azaz külön-külön meghatározható, hogy egy adott modul által felderített vírus eltávolítására milyen művelet hajtódjon végre.
Vírustalálati ablak
Az üzenet ablak felső részben az üzenetet küldő modul ikonja és neve található. Innen tájékozódhat, hogy mely védelmi komponens jelzi a vírust. A középső piros sávban tudhatja meg a fertőzés jellegét, felette rövid információt kap az irtás módjáról, az esetleges további teendőkről. A piros sáv alatt a fertőzött fájl és útvonala-, mellette – ha az adat rendelkezésre áll – a felismert vírus neve olvasható.
Az interaktív panel alsó harmadában megjelenő gombsorból választhatja ki a végrehajtandó műveletet a rendelkezésre álló akciók közül.
Az Állandó védelem modul által jelzett incidensekről csak figyelmeztető üzenetet küld(het) a program, a felderített fertőzés kezelése a modul Találati beállításainál meghatározott módon történik.
Az ablak jobb felső sarkában található |X| gombra kattintáskor a Meghagy művelet hajtódik végre az aktuális incidensre vonatkozva.
Az Alkalmaz mindenre jelölőnégyzet bejelölése után, az adott típusú vírustalálatról nem küld jelzést a rendszer, a továbbiakban a kiválasztott művelet fog végrehajtódni az összes hasonló típusú vírusincidens alkalmával.

Figyelmeztetések

Ezek az üzenetek egy-egy – felhasználó által kezdeményezett – művelet végrehajtása nyomán fellépő egyéb változásokról, a kezdeményezett művelet hatásairól, végeredményéről adnak tájékoztatást.
Figyelmeztető üzenet
Az ablak megjelenésében hasonlít a vírusfertőzéskor megjelenő üzenet ablakra. Felső részében annak a modulnak az ikonja és neve olvasható, amelyik az üzenetet küldte. A narancssárga színű sáv alatt az üzenet tartalma olvasható, a részletek ablakban az üzenettel kapcsolatos bővebb leírás olvasható, mely a Részletek sáv jobb oldalán látható lefelé mutató nyílra kattintással tekinthető meg.
A rendelkezésre álló |Rendben| gombbal tudomásul veszi az üzenetet, illetve folytatja a megkezdett műveletet, ha rendelkezésre áll |Elvet| gomb, azzal törölheti az előzőleg kezdeményezett feladat végrehajtását.


Gyakran Ismételt Kérdések

Általános

• Van érvényben lévő licencem a VirusBuster korábbi verziójára. Használhatom-e ezeket az adatokat a VirusBuster 2006-os változathoz?
Igen.
A VirusBuster új, 2006-os verziójú termékei a korábbi termékhez megvásárolt licencen szereplő lejárat dátumáig használhatók a licencen szereplő felhasználói név, regisztrációs kulcs adatokkal.
• Mi a különbség az aktiváció és a regisztráció között?
Azok az ügyfelek, akik aktivációs kulcsot kapnak (3x4 karakter) aktiválhatják a programjukat akár e-mail-en, akár SMS-en keresztül. Akik e-mail-ben aktiválják a programot, a megadott e-mail címükre küldi vissza a szerver a regisztrációs kulcsot (3x5 karakter) és a felhasználói nevet, az SMS-sen keresztüli aktiváció után pedig SMS-ben kerül visszaküldésre a regisztrációs kulcs amivel a program beregisztrálható.
A regisztrációs kulccsal rendelkező ügyfelek közvetlenül be tudják regisztrálni a programot a regisztrációs adatok (regisztrációs kulcs, felhasználói név) bevitelével.
• Véd-e a termék az ún. spyware és adware programoktól?
A legtöbb esetben ezek a programok legális weboldalról, vagy legális telepítőkészletből kerülnek fel, a felhasználó aktív közreműködésével. A VirusBuster az adware/spyware csoportból azokat ismeri fel, amiket agresszív vagy nem legális módon terjesztenek, vagy települnek fel a gépekre, illetve amelyek a rendszeren az átlagosnál nagyobb kényelmetlenséget okoznak.
Ezek a programok szorosan integrálódnak általában az Internetes böngészőbe, nem megfelelő eltávolításuk több gondot okozhat, mint a jelenlétük. Felismerésük nem irtható kártevőként kerül be a programba, azzal, hogy az eltávolítást a legtöbb esetben a Windows Programok Telepítése/Eltávolítása (Add/Remove Programs) szolgáltatásával lehet végrehajtani.

Telepítés/Frissítés

• Napi/heti időzítésű (bejelentkezéskori), alapértelmezett forrásra beállított frissítő feladatok nem indulnak el automatikusan, a naplóban 12007 -es hibakód olvasható.
Ellenőrizni kell hogy elérhető-e a www.virusbuster.hu szerver az adott gépről. (parancssorból adja ki a következő utasítást: ping -a www.virusbuster.hu).
Amennyiben nem elérhető, akkor a rendszer tűzfal- és DNS beállításait kell felülvizsgálni. Ez utóbbira megoldásként vegye fel a System32\drivers\etc\ útvonalon található hosts fájlba a www.virusbuster.hu -t a 195.228.45.67 IP címmel (a hosts fájl elérési útja rendszerenként változó).
Ha ezután sem működik akkor a registry -ben az alábbi kulcs értékét kell módosítani: HKEY_LOCAL_MACHINE\Software\VirusBuster Team\TaskMan alatt a NetTest vátózónak localhost értéket kell adni.
• ISA szerveren keresztül nem frissít a VirusBuster, sem az adatbázis-, sem a programfrissítés nem fut le. Mi a teendő?
Telepíteni kell az ISA Firewall Client alkalmazást azokra a gépekre, amelyeken VirusBuster program fut. A Firewall Client képes authentikált kapcsolatot létesíteni az ISA szerver felé, így a frissítő feladatok is képesek lesznek az állományokat letölteni az ISA szerveren keresztül. További információ www.isaserver.org
• WinXP SP2 rendszeren a Windows beépített tűzfala be van kapcsolva, és sem a program-, sem az adatbázis-frissítés nem fut le. A naplóban 183-as hibakód olvasható. Mi a teendő?
A jelenség nem csak a Windows saját tűzfalára, hanem egyéb más telepített tűzfalra is érvényes (pl: Kerio, ZoneAlarm, Outpost stb.).
Teendő:
Amennyiben az első telepítés után indítja el a frissítőt, vagy az elindul automatikusan (ez beállítás kérdése), akkor a tűzfal jelezni fogja a kapcsolódási szándékot. Ilyen esetben a "Tiltás feloldása" ("Unblock") opciót kell választani WinXP SP2 esetén, illetve engedélyezni a műveletet egyéb tűzfal program esetén.
• Telepítéskor hibaüzenettel leáll a telepítő, pl: "...msvcp60.dll nem található...".
Hasonló hibaüzenetek esetén kérjük használja a 'VirusBuster Redist Installer and Checker' telepítő csomagot a hiányzó vagy sérült fájlok pótlására. A csomag elérhetőségét és további információkat a readmehu.txt fájl tartalmaz, mely a telepítőkészletben található.
• Tud-e a termék automatikusan adatbázist, illetve programverziót frissíteni?
Igen.
A termék telepítése során két alapértelmezett frissítési feladat kerül felvételre (kivéve, ha valaki a telepítés során törli a feladatok telepítését).
Az adatbázist frissítő feladat napi rendszerességgel, a programot frissítő feladat heti rendszerességgel fut le. A frissítés lefutásának feltétele hogy van hálózati kapcsolat, és nem blokkolja tűzfal program a frissítési feladat által kezdeményezett hálózati kapcsolatot a frissítés forrásaként beállított szerverekkel.
• Az alábbi hibakóddal kapok hibaüzenetet... Mi a teendő?
Az alább említett felhasználói név/jelszó párossal meghatározott felhasználó-beállítások a következő helyeken fordulhatnak elő:
MMC felhasználói felület:
(1) Az alapértelmezetten beállított felhasználó a VirusBuster konzol > Közös > Általános beállítások > Jogosultság hálózati kapcsolathoz útvonalon.
(2) A frissítési feladatokhoz, illetve a telepítő másoló feladatokhoz adható meg felhasználó, mely az adott feladat ütemezési tulajdonság-lapjának a Biztonság fülén található Egyéni felhasználó adatai opcióban állítható be. Az alapértelmezett, és az újonnan létrehozott frissítési-, illetve telepítő másoló feladatok alapértelmezetten az első (1) beállításban megadott felhasználói adatokat használják.
Varázsló alapú felület:
Egy Programfrissítő feladathoz tartozó felhasználó név/jelszó beállítás az Ütemezés panelon érhető el.
Hibakód: 3
Ellenőrizni kell a megadott elérési út helyességét, főleg a frissítési útvonalak szoktak problémásak lenni. Ellenőrizze, hogy a megadott elérési utak valósak és érvényesek.
Hibakód: 5 vagy 65
Ellenőrizze, hogy a megadott felhasználói név/jelszó párossal meghatározott felhasználónak megvannak-e a megfelelő (legalább olvasási) jogosultsága az adott fájllal, illetve könyvtárral kapcsolatban.
A 65-ös hibakód esetén hálózati útvonalakkal kapcsolatos a hiba.
Hibakód: 1326
A megadott felhasználói név/jelszó párossal meghatározott felhasználó hibás, vagy nem létezik, ellenőrizze a beírt adatokat - törölje ki és gépelje be újra.
• A telepítő indításakor a következő hibaüzenet jelenik meg: "1607: Az InstallShield Scripting Runtime nem telepíthető".
Egy hiányzó registry kulcs következménye lehet, ami rendszerint az ISScript.msi telepítésekor jött létre egy másik program korábbi telepítésekor.
Teendő:
A C:\Program Files\Common Files\InstallShield\Driver\7\Intel 32 könyvtárból az IDriver.exe állományt "drag and drop" módszerrel húzza bele a Start > Futtatás ablakba majd írja be az exe fájl után a /regsrv paramétert. Nyomja meg az |OK| gombot! Próbálja meg a telepítést még egyszer.
• Mit tegyek, ha a termék telepítésekor az 'RPC stub nem kompatibilis verziója. A telepítés megszakad.' hibaüzenet jelenik meg?
Amennyiben az MS Office 2000 vagy annak valamelyik komponense telepítve van a rendszerén akkor a
http://www.microsoft.com/downloads/details.aspx?FamilyID=3CA24EF2-72EC-4DC1-B092-DFA114329486&displaylang=EN
oldalon található javítócsomagot kell letöltenie és futtatnia.
Ha nincs fenn az említett Office verzió akkor a
http://download.microsoft.com/download/msninvestor/patch/1.0/win98/en-us/mcrepair.exe
linkre kattintva töltse le az mcrepair.exe programot, majd futassa le. Engedje a már létező állományok felülírását, a telepítés után indítsa újra rendszerét.

Működés

• Nem tudom módosítani az egyes beállítások értékét!
Lehetséges, hogy adminisztrátori jelszó van beállítva a termékben, mely korlátozza bizonyos beállítások módosíthatóságát. Az adminisztrációs jelszó megadása (vagy törlése) után a beállítások újból módosíthatóvá válnak.
Az is lehetséges, hogy alacsony szintű felhasználóként jelentkezett be a rendszerbe, melynek nincs joga az egyes beállítások módosításához.
Teendő:
Kattintson az Adminisztráció menüpontra a bal oldali menüben, majd adja meg a helyes jelszót!
Ha alacsony szintű felhasználóként van jelen a rendszerben, és emiatt nem tudja módosítani a beállításokat, akkor lépjen ki a rendszerből, és jelentkezzen be rendszergazdai jogosultsággal rendelkező felhasználóként.
• Windows XP SP2 -re telepítve a terméket, a Windows Biztonsági Központ nem jelzi vírusvédelem jelenlétét. Mi lehet a baj?
Ellenőrizze hogy a 'Path' környezeti változóban szerepel-e a "%SystemRoot%\System32\Wbem" elérési út. Amennyiben nem, kérjük adja hozzá, majd indítsa újra a rendszert.
(A Start > Beállítások > Vezérlőpult > Rendszer > Speciális lap alján a |Környezeti változók| gombra kattintva, és a 'Path'-ot kijelölve a |Szerkesztés| gombbal tudja hozzáadni a hiányzó útvonalat egy ; (pontosvessző) után.)

Tartalomszűrő

• Mely programokkal (kliensekkel) működik biztosan együtt a Tartalomszűrő?
A Tartalomszűrő szolgáltatás számos (kliens) program használata esetén alkalmazható. A következő alkalmazások biztosan együttműködnek a Tartalomszűrővel:
Böngészők:
Internet Explorer 6.0
Opera 7.54
Mozilla FireFox 1.0
Netscape 7.2
FTP kliensek:
Total Commander 6.0
Far
Levelező kliensek (POP3, IMAP, SMTP):
Outlook
Outlook Express
Mozilla Thunderbirds
The Bat (IMAP kivételével)
Netscape
Pegasus Mail
A fenti alkalmazásokkal való együttműködés teszteléssel igazolt. Természetesem egyéb más programokkal együtt is használható a Tartalomszűrő modul, azonban ezeknél a hibátlan működés nem garantált.
A Tartalomszűrő alkalmas a különböző letöltés-vezérlőkkel letöltött adatok vizsgálatára is abban az esetben, ha azok egy szálon végzik az adatok letöltését!
• Mit tegyek, ha nem működik a Tartalomszűrő Netscape böngésző használata esetén!
Ha a böngészőben be van kapcsolva a Quick launch funkció (Edit/Preferences/Advanced/’Enable quick launch’ ki van jelölve), akkor a VirusBuster telepítése után a Tartalomszűrő funkció helyes működéséhez teljesen le kell állítania a Netscape futását, majd újraindítás után a Tartalomszűrő már a Netscape forgalmát is ellenőrzi.
Teendő:
A teljes leállításhoz ki kell lépnie a Netscape-ből a tálcán lévő gyorsindítás (quick launch) ikon segítségével. Miután bezárta a Netscape ablakot, kattintson az ikonra az egér jobb gombjával és a megjelenő helyi menüben válassza az ’Exit Netscape’ menüpontot.


KAPCSOLAT

Jelen dokumentáció átfogó ismereteket nyújt vírusvédelmi programunk működéséről, működtetéséről, ennek ellenére, ha további kérdése van termékünkkel kapcsolatban, esetleg megosztaná velünk észrevételeit, javaslatait, kérjük lépjen kapcsolatba velünk. Bizalommal forduljon hozzánk az alábbi elérhetőségek egyikén, kéréseit, megjegyzéseit, ötleteit szívesen fogadjuk.
Cím | VirusBuster Kft.
 | Budapest 1116,
 | Vegyész u. 17-25.
 | Magyarország
Telefon | (+36) 1 382-7000
Fax | (+36) 1 382-7007
Web | www.virusbuster.hu
E-mail | mail@virusbuster.hu